Project

General

Profile

Bug #14212

Logger uses Kernel.#open to open a file, so it can open something more than files

Added by sonots (Naotoshi Seo) about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-dev:50380]

Description

It is not intended behavior.

Associated revisions

Revision 61378
Added by sonots (Naotoshi Seo) about 1 month ago

  • lib/logger.rb (Logger::LogDevice#open_logfile, #create_logfile): Logger should be able to open only files [Bug #14212]

History

#1 Updated by sonots (Naotoshi Seo) about 1 month ago

  • Status changed from Open to Closed

Applied in changeset trunk|r61378.


  • lib/logger.rb (Logger::LogDevice#open_logfile, #create_logfile): Logger should be able to open only files [Bug #14212]

Also available in: Atom PDF