Project

General

Profile

Actions

Bug #14477

closed

tzdata 2018c seems break test suite

Added by normalperson (Eric Wong) almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:85559]

Description

Upgraded tzdata to 2018c on both my Debian stretch (stable) and jessie
(oldstable) machines via "apt-get dist-upgrade" and noticed test failures:

[  4/325] TestTimeTZ#test_asia_tokyo = 0.00 s
  1) Failure:
TestTimeTZ#test_asia_tokyo [$HOME/ruby/test/ruby/test_time_tz.rb:129]:
TZ=Asia/Tokyo Time.local(1951, 5, 6, 2, 0, 0).
<"1951-05-06 03:00:00 +1000"> expected but was
<"1951-05-06 02:00:00 +1000">.

[ 62/325] TestTimeTZ#test_gen_Asia_Tokyo_24 = 0.00 s
  2) Failure:
TestTimeTZ#test_gen_Asia_Tokyo_24 [$HOME/ruby/test/ruby/test_time_tz.rb:259]:
TZ=Asia/Tokyo Time.utc(1951, 5, 5, 16, 59, 59).localtime.
<"1951-05-06 01:59:59 +0900"> expected but was
<"1951-05-06 02:59:59 +1000">.

[ 65/325] TestTimeTZ#test_gen_Asia_Tokyo_27 = 0.00 s
  3) Failure:
TestTimeTZ#test_gen_Asia_Tokyo_27 [$HOME/ruby/test/ruby/test_time_tz.rb:259]:
TZ=Asia/Tokyo Time.utc(1951, 9, 7, 16, 0, 0).localtime.
<"1951-09-08 01:00:00 +0900"> expected but was
<"1951-09-08 02:00:00 +1000">.

[ 66/325] TestTimeTZ#test_gen_Asia_Tokyo_69 = 0.00 s
  4) Failure:
TestTimeTZ#test_gen_Asia_Tokyo_69 [$HOME/ruby/test/ruby/test_time_tz.rb:277]:
TZ=Asia/Tokyo Time.local(1951, 5, 6, 1, 59, 59).
<"1951-05-06 01:59:59 +0900"> expected but was
<"1951-05-06 01:59:59 +1000">.

[ 69/325] TestTimeTZ#test_gen_Asia_Tokyo_72 = 0.00 s
  5) Failure:
TestTimeTZ#test_gen_Asia_Tokyo_72 [$HOME/ruby/test/ruby/test_time_tz.rb:295]:
TZ=Asia/Tokyo Time.local(0, 0, 1, 8, 9, 1951, nil, nil, false, nil).
<"1951-09-08 01:00:00 +0900"> expected but was
<"1951-09-08 01:00:00 +1000">.

Not an expert on TZ so I'll let somebody else deal with this. Thanks.


Related issues

Is duplicate of Ruby master - Bug #14438: TestTimeTZ: failures with recent version of tzdataClosedActions
Actions #1

Updated by vo.x (Vit Ondruch) almost 4 years ago

  • Is duplicate of Bug #14438: TestTimeTZ: failures with recent version of tzdata added
Actions #2

Updated by vo.x (Vit Ondruch) almost 4 years ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF