Project

General

Profile

Actions

Bug #14589

closed

"No implicit conversion of XXX to string" asserion should be handled with an explicit string conversion, and it should be a warning not an assertion

Added by Anon92929 (Anon Ymous) almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:86014]

Description

Too many people's time have been wasted trying to make sure their puts/prints statements don't assert because of failed implicit string conversions. This should be handled by an explicit .to_s attempt, and a warning instead of a break.


Related issues

Is duplicate of Ruby master - Bug #13929: TypeError: no implicit conversion of XXXX into stringRejectedActions

Updated by Hanmac (Hans Mackowiak) almost 4 years ago

learn the difference between to_s and to_str
one is explicit, the other is implicit

Actions #2

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Is duplicate of Bug #13929: TypeError: no implicit conversion of XXXX into string added

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Status changed from Open to Rejected
  • Description updated (diff)

It's not a good idea to hide a failure and continue with a garbage.

Actions

Also available in: Atom PDF