Project

General

Profile

Bug #14733

Error on reading log4r

Added by cardillos (cherry ard) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.6p384 (2017-12-14 revision 9808)
[ruby-core:86861]

Description

Hello all,
I used Vagrant on Windows 10 which is using Ruby.
Here is the error on the log

!verror.png!

Any idea anyone?


Files

verror.png (8.48 KB) verror.png cardillos (cherry ard), 05/03/2018 06:49 AM

Updated by shevegen (Robert A. Heiler) over 2 years ago

The error says missing log4r.

I think this is not related to ruby core - the tracker here is about
ruby itself, not external dependencies.

If it is just a gem missing, "gem install log4r" should work.

https://rubygems.org/gems/log4r/

That gem has not been updated in 6 years, though, so I would not
think this to work very reliably.

(It's also strange that you can use vagrant, but vagrant would fail
via a missing log4r gem; something is most likely not properly setup
on your system.)

Updated by cardillos (cherry ard) over 2 years ago

Thanks for the update. However I checked the gem directory and I can find log4r in it.
It just weird I cant run the system because it's stuck on this error.

Updated by gotoken (Kentaro Goto) over 2 years ago

  • Status changed from Open to Rejected

I tried to reproduce the issue because I have Vagrant 2.0.4 on Windows 10 1709 by chance. I cannot reproduce though. vagrant ssh succeed. Your screenshot shows that ruby runs in the debian box but vanilla wheezy box does not include ruby. See log the below. Show

Any way, this issue is not a problem of ruby interpreters nor ruby language and I set status reject.

You might get helps at the issue tracker of the box you used or at ruby-talk mailing list.

Updated by cardillos (cherry ard) over 2 years ago

  • Status changed from Rejected to Closed

It works fine now and I don't know what happened. Thanks anyway.

Cheers!

Also available in: Atom PDF