Project

General

Profile

Bug #15232

Is https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.2.tar.bz2 corrupted?

Added by wanabe (_ wanabe) about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:89451]

Description

Hello,

I'm glad for new ruby release. Thank you so much.

I tried to build ruby-2.5.2 in docker environment, but I couldn't and got a such error.

[root@9838dd79fcdd tmp]# rbenv install 2.5.2
Downloading ruby-2.5.2.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.2.tar.bz2
Installing ruby-2.5.2...

BUILD FAILED (CentOS release 6.10 (Final) using ruby-build 20180822-14-gcbbd3c2)

Inspect or clean up the working tree at /tmp/ruby-build.20181018003202.361
Results logged to /tmp/ruby-build.20181018003202.361.log

Last 10 log lines:
/tmp/ruby-build.20181018003202.361 /tmp
/tmp/ruby-build.20181018003202.361/ruby-2.5.2 /tmp/ruby-build.20181018003202.361 /tmp
checking for ruby... false
configure: error: cannot run /bin/sh tool/config.sub

I guess tool/config.sub and tool/config.guess are corrupted unexpectedly.

[root@9838dd79fcdd tmp]# ls -la /tmp/ruby-build.20181018003202.361/ruby-2.5.2/tool/config.*
lrwxrwxrwx 1 1044 1044 33 Oct 18 00:32 /tmp/ruby-build.20181018003202.361/ruby-2.5.2/tool/config.guess -> ../.downloaded-cache/config.guess
lrwxrwxrwx 1 1044 1044 31 Oct 18 00:32 /tmp/ruby-build.20181018003202.361/ruby-2.5.2/tool/config.sub -> ../.downloaded-cache/config.sub

On another environment that has BASERUBY, I confirmed to run configure.

/tmp/ruby-2.5.2 $ ./configure
checking for ruby... /home/wanabe/.rbenv/shims/ruby
downloading config.guess ... done
downloading config.sub ... done
(snip)
Dockerfile (461 Bytes) Dockerfile wanabe (_ wanabe), 10/18/2018 11:39 PM

History

#1 [ruby-core:89454] Updated by nagachika (Tomoyuki Chikanaga) about 1 month ago

  • Assignee set to nagachika (Tomoyuki Chikanaga)
  • Status changed from Open to Assigned

Thank you for your report.
Sorry for bother you. It seems that I had made a mistake in packaging.
As you commented, ruby-2.5.2 packages requires BASERUBY to build. It's not intended.

I will take a look into tool/make-snapshot and release fixed package with version 2.5.3.
I have heard that usa-san confirmed that the 2.4.5 and 2.3.8 packages don't have this issue.

#2 [ruby-core:89462] Updated by wanabe (_ wanabe) about 1 month ago

  • Backport changed from 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN to 2.3: DONTNEED, 2.4: DONTNEED, 2.5: DONTNEED
  • Status changed from Assigned to Closed
  • File Dockerfile Dockerfile added

I saw https://www.ruby-lang.org/en/news/2018/10/18/ruby-2-5-3-released/ and https://github.com/rbenv/ruby-build/pull/1241 .
Thank you for your quick and accurate response.

I confirmed that ruby-2.5.3 doesn't have the issue.

[root@cd10e9d4c1fd /]# rbenv install 2.5.3
Downloading ruby-2.5.3.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.3.tar.bz2
Installing ruby-2.5.3...
Installed ruby-2.5.3 to /opt/rbenv/versions/2.5.3

So I close the ticket and change Backport status "DONTNEED".
Thank you!

Also available in: Atom PDF