Project

General

Profile

Bug #15291

ruby-2.6.0-preview3でbin/bundle_rubyがインストールされる

Added by kimuraw (Wataru Kimura) 13 days ago. Updated 12 days ago.

Status:
Assigned
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.6.0dev (2018-11-07 trunk 65606) [x86_64-darwin18]
[ruby-dev:50663]

Description

ruby-2.6.0-preview3を試していたところ、bin/以下に"bundle_ruby"というファイルがありました。
bundler由来のもののようですが、これは意図されたものでしょうか?

gem install bundlerでインストールしたときには"bundle_ruby"は作成されないようです。

% gem install bundler
  :
% gem spec bundler version
--- !ruby/object:Gem::Version
version: 1.17.1

% gem spec bundler executables
---
- bundle
- bundler

以下のバージョンで同様の状況を確認しました。

  • ruby-2.6.0-preview3
  • trunk r65606

History

#1 [ruby-dev:50664] Updated by hsbt (Hiroshi SHIBATA) 12 days ago

  • Assignee set to hsbt (Hiroshi SHIBATA)
  • Status changed from Open to Assigned

bundle_ruby が無いと落ちるテストがあったので port してましたが、リリースまでにはテストと一緒に消しておこうと思います。

Also available in: Atom PDF