Project

General

Profile

Bug #15333

make check fails looking for Bundler 2.0

Added by leam (Leam Hall) 20 days ago. Updated 13 days ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.6.0dev (2018-10-17 trunk 65108) [x86_64-linux]
[ruby-core:89992]

Description

Just pulled the latest trunk from github. The log from "make check" seems to indicate a bundler 2.0 missing. Using bundler 1.17.1 installed by gem.

ruby -v: ruby 2.6.0dev (2018-11-23 trunk 65931) [x86_64-linux]
making mjit_build_dir.so
const char MJIT_BUILD_DIR[] = "/usr/local/src/ruby";
/usr/local/src/ruby/lib/rubygems/resolver.rb:231:in search_for': Unable to resolve dependency: use
r requested 'bundler (= 2.0.0.pre.1)' (Gem::UnsatisfiableDependencyError)
from /usr/local/src/ruby/lib/rubygems/resolver.rb:283:in
block in sort_dependencies'

ruby_make_check_20181122_1832.log (14.5 KB) ruby_make_check_20181122_1832.log leam (Leam Hall), 11/22/2018 11:55 PM
ruby_configure_20181122_1832.log (27.5 KB) ruby_configure_20181122_1832.log leam (Leam Hall), 11/22/2018 11:55 PM
ruby_make_20181122_1832.log (96.5 KB) ruby_make_20181122_1832.log leam (Leam Hall), 11/22/2018 11:55 PM

History

#1 [ruby-core:90065] Updated by hsbt (Hiroshi SHIBATA) 17 days ago

  • Assignee set to hsbt (Hiroshi SHIBATA)
  • Status changed from Open to Assigned

#3 [ruby-core:90140] Updated by hsbt (Hiroshi SHIBATA) 14 days ago

  • Status changed from Assigned to Feedback

I couldn't reproduce it.

#4 [ruby-core:90144] Updated by leam (Leam Hall) 14 days ago

I will build a clean box and try again. Thank you.

#5 [ruby-core:90151] Updated by MSP-Greg (Greg L) 14 days ago

hsbt (Hiroshi SHIBATA)

By no means have I looked at how Bundler is used by RG testing, but in trunk, the following line in test_case.rb works in rubygems/rubygems, but not trunk:

# If bundler gemspec exists, add to stubs
bundler_gemspec = File.expand_path("../../../bundler/bundler.gemspec", __FILE__)

https://github.com/rubygems/rubygems/blob/master/lib/rubygems/test_case.rb#L17

JFYI, ruby-loco runs test-all with runner.rb from ruby.exe in the install folder, so...

#6 [ruby-core:90181] Updated by leam (Leam Hall) 13 days ago

My original failure was on a Fedora 28 box. I am building a CentOS 7 box and still getting the build environment set up for a totally clean build. I apologize for the delay.

#7 [ruby-core:90192] Updated by leam (Leam Hall) 13 days ago

  • Status changed from Feedback to Closed

Build on a totally clean CentOS 7 box passed without failure. I would attribute this issue to "user's host configuration".

Also available in: Atom PDF