Project

General

Profile

Bug #15392

Crash in RubyVM::InstructionSequence#to_binary

Added by clayton-shopify (Clayton Smith) 10 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-darwin18]
[ruby-core:90371]

Description

The following program causes a crash in Ruby 2.5.3 and 2.5.1 (but not in 2.4.4):

RubyVM::InstructionSequence.compile('a(b: 0) if false').to_binary


Files

crash.rb (66 Bytes) crash.rb clayton-shopify (Clayton Smith), 12/07/2018 03:18 PM
ruby_2018-12-07-101547_Claytons-MacBook-Pro.crash (38 KB) ruby_2018-12-07-101547_Claytons-MacBook-Pro.crash clayton-shopify (Clayton Smith), 12/07/2018 03:18 PM

Related issues

Related to Ruby master - Bug #15200: RubyVM::InstructionSequence can not compile to binary from method call with hash in 'if false' expressionClosedActions

History

Updated by shyouhei (Shyouhei Urabe) 10 months ago

It seems fixed on my machine. Can be a dup of #14897 ?

Updated by clayton-shopify (Clayton Smith) 10 months ago

shyouhei (Shyouhei Urabe) wrote:

It seems fixed on my machine. Can be a dup of #14897 ?

The symptoms I observed are the same as #15200, so I expect it is a duplicate of that issue.

#3

Updated by jeremyevans0 (Jeremy Evans) about 2 months ago

  • Related to Bug #15200: RubyVM::InstructionSequence can not compile to binary from method call with hash in 'if false' expression added
#4

Updated by jeremyevans0 (Jeremy Evans) about 2 months ago

  • Status changed from Open to Closed

Also available in: Atom PDF