Project

General

Profile

Bug #15643

Partly Backport RubyGems 3.0.3 to Ruby 2.5(with RubyGems 2.7.6)

Added by hsbt (Hiroshi SHIBATA) about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:91695]

Description

The rubygems team changed the behavior of BundlerVersionFinder.
It makes detecting only the major version of Bundler from strict version matching.

This patch can be applied after https://bugs.ruby-lang.org/issues/15637


Files

rubygems-2.7.6.2.patch (7.22 KB) rubygems-2.7.6.2.patch hsbt (Hiroshi SHIBATA), 03/06/2019 07:48 AM

Associated revisions

Revision 7244db9d
Added by nagachika (Tomoyuki Chikanaga) about 1 month ago

Merge RubyGems 2.7.6.2 patch [Bug #15643]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_5@67235 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 67235
Added by nagachika (Tomoyuki Chikanaga) about 1 month ago

Merge RubyGems 2.7.6.2 patch [Bug #15643]

History

#1

Updated by hsbt (Hiroshi SHIBATA) about 2 months ago

  • Backport changed from 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN to 2.4: DONTNEED, 2.5: REQUIRED, 2.6: DONTNEED
  • Status changed from Open to Closed

Updated by nagachika (Tomoyuki Chikanaga) about 1 month ago

  • Backport changed from 2.4: DONTNEED, 2.5: REQUIRED, 2.6: DONTNEED to 2.4: DONTNEED, 2.5: DONE, 2.6: DONTNEED

The patch was merged at r67235.

Also available in: Atom PDF