Project

General

Profile

Bug #16036

workers keep on crashing with [BUG] Segmentation fault at 0x000000010b647a3a

Added by jitensachdeva (Jitendra Sachdeva) about 1 year ago. Updated about 1 year ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.3p105
[ruby-core:94105]

Description

My redis worker keep on crashing with message /

Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/connection/ruby.rb:210: [BUG] Segmentation fault at 0x000000010b647a3a
ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-darwin18]

-- Crash Report log information --------------------------------------------
See Crash Report log file under the one of following:
* ~/Library/Logs/DiagnosticReports
* /Library/Logs/DiagnosticReports
for more details.
Don't forget to include the above Crash Report log file in bug reports.

-- Control frame information -----------------------------------------------
c:0041 p:---- s:0203 e:000202 CFUNC :getaddrinfo
c:0040 p:0034 s:0195 e:000194 METHOD /Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/connection/ruby.rb:210
c:0039 p:0161 s:0187 e:000186 METHOD /Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/connection/ruby.rb:317
c:0038 p:0070 s:0180 e:000179 METHOD /Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/client.rb:349
c:0037 p:0005 s:0175 e:000174 BLOCK /Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/client.rb:106
c:0036 p:0016 s:0172 e:000171 METHOD /Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/client.rb:306
c:0035 p:0020 s:0166 e:000165 METHOD /Users/jitendrasachdeva/.rvm/gems/ruby-2.5.3/gems/redis-4.1.2/lib/redis/client.rb:105

The details are attached


Files

ruby_2019-08-02-052206-3_Jitendras-MacBook-Pro.crash (48 KB) ruby_2019-08-02-052206-3_Jitendras-MacBook-Pro.crash crash report jitensachdeva (Jitendra Sachdeva), 08/02/2019 12:19 AM
console.txt (967 KB) console.txt jitensachdeva (Jitendra Sachdeva), 08/02/2019 12:20 AM

Related issues

Is duplicate of Ruby master - Bug #15490: socket.rb - recurring segmentation faultsThird Party's IssueActions
#1

Updated by jitensachdeva (Jitendra Sachdeva) about 1 year ago

  • Subject changed from Redis workers keep on crashing with [BUG] Segmentation fault at 0x000000010b647a3a to workers keep on crashing with [BUG] Segmentation fault at 0x000000010b647a3a
#2

Updated by mame (Yusuke Endoh) about 1 year ago

  • Is duplicate of Bug #15490: socket.rb - recurring segmentation faults added

Updated by mame (Yusuke Endoh) about 1 year ago

  • Status changed from Open to Rejected

I believe this is a duplicate of #15490.

Updated by jitensachdeva (Jitendra Sachdeva) about 1 year ago

When we say it's related to third party issue, which third party we meant here, is it OSX that is causing this issue ?

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Status changed from Rejected to Third Party's Issue

Yes, getaddrinfo is an API function provided by OS vendors, that is Apple in this case.

Also available in: Atom PDF