Project

General

Profile

Actions

Bug #17665

closed

Make failed on x86_64-cygwin (miniruby.exe segmentation fault)

Added by fd0 (Daisuke Fujimura) about 2 months ago. Updated 22 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 3.1.0dev (2021-02-27T16:42:49Z master 5c9079759d) [x86_64-cygwin]
[ruby-core:102653]

Description

Make failed on x86_64-cygwin (miniruby.exe segmentation fault)

$ git clone https://github.com/ruby/ruby.git
$ cd ruby
$ autoreconf -fiv && ./configure && make V=1
(snip)
./miniruby.exe -I./lib -I. -I.ext/common  ./tool/generic_erb.rb -c -o encdb.h ./template/encdb.h.tmpl ./enc enc
make: *** [uncommon.mk:1098: encdb.h] Segmentation fault (core dumped)
$

This problem seems to have occurred since 1e13548953659bd12c28625d45998322449f3be8.

Segmentation faults can be avoided by not using mmap.


Files

not-use-mmap-on-cygwin.patch (858 Bytes) not-use-mmap-on-cygwin.patch fd0 (Daisuke Fujimura), 02/28/2021 10:57 AM

Updated by xtkoba (Tee KOBAYASHI) about 2 months ago

Not using mmap(2) may be a workaround, but there is a drawback of GC compaction being not usable.

Updated by fd0 (Daisuke Fujimura) about 1 month ago

Would you please try the patch in #17652#note-5 ?

Applying the patch, I have confirmed that segmentation fault does not occur.

$ ./miniruby.exe -v
ruby 3.1.0dev (2021-02-28T11:24:42Z master 80e2c45f55) [x86_64-cygwin]

Updated by peterzhu2118 (Peter Zhu) about 1 month ago

Thanks for reporting the issue in cygwin. I've proposed a patch that should solve the issue.

Actions #5

Updated by peterzhu2118 (Peter Zhu) 22 days ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF