Project

General

Profile

Actions

Bug #17940

closed

Bus Error

Added by abdulaalsj@g.cofc.edu (summer abdulaal) about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby--3.0.1.arm64_big_sur.bottle.tar.gz
[ruby-core:104196]

Description

/Library/Ruby/Gems/2.6.0/gems/ffi-1.15.1/lib/ffi/library.rb:275: [BUG] Bus Error at 0x00000001050bc000
ruby 2.6.3p62 (2019-04-16 revision 67580) [universal.arm64e-darwin20]

-- Crash Report log information --------------------------------------------
See Crash Report log file under the one of following:

* ~/Library/Logs/DiagnosticReports

* /Library/Logs/DiagnosticReports

for more details.

Don't forget to include the above Crash Report log file in bug reports.

Updated by jeremyevans0 (Jeremy Evans) about 2 months ago

  • Status changed from Open to Feedback

In general, if you are using FFI and get a Bus Error, it is unlikely to be a bug in Ruby. It is more likely this is an issue where third party software was written for x86 and doesn't work correctly on M1 Macs. It's hard to determine exactly where the problem is because you didn't include the Crash Report log. Can you upload the Crash Report log?

Updated by xtkoba (Tee KOBAYASHI) about 2 months ago

There is too little information to judge now, but my prejudication is that this is the same issue as in #17922 (and a whole bunch of other similar issues for a specific extension.)

Actions #3

Updated by jeremyevans0 (Jeremy Evans) about 1 month ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF