Project

General

Profile

Actions

Misc #18192

closed

Advertise that OpenSSL 3.0 is not supported

Added by xtkoba (Tee KOBAYASHI) about 1 month ago. Updated 11 days ago.

Status:
Third Party's Issue
Priority:
Normal
[ruby-core:105419]

Description

Can we document that OpenSSL 3.0 is not supported?

I believe at least we can make extconf.rb fail with OpenSSL 3.0:

--- a/ext/openssl/extconf.rb
+++ b/ext/openssl/extconf.rb
@@ -108,10 +108,12 @@
     try_static_assert("LIBRESSL_VERSION_NUMBER >= 0x30100000L", "openssl/opensslv.h") }
 else
   checking_for("OpenSSL version >= 1.0.2") {
-    try_static_assert("OPENSSL_VERSION_NUMBER >= 0x10002000L", "openssl/opensslv.h") }
+    try_static_assert("OPENSSL_VERSION_NUMBER >= 0x10002000L", "openssl/opensslv.h") } &&
+  checking_for("OpenSSL version < 3.0.0") {
+    try_static_assert("OPENSSL_VERSION_NUMBER < 0x30000000L", "openssl/opensslv.h") }
 end
 unless version_ok
-  raise "OpenSSL >= 1.0.2 or LibreSSL >= 3.1.0 is required"
+  raise "OpenSSL >= 1.0.2, < 3.0.0 or LibreSSL >= 3.1.0 is required"
 end

 # Prevent wincrypt.h from being included, which defines conflicting macro with openssl/x509.h

Updated by rhenium (Kazuki Yamaguchi) about 1 month ago

  • Assignee set to rhenium (Kazuki Yamaguchi)

Adding OpenSSL 3.0 support is planned for the next Ruby/OpenSSL gem release, for inclusion in Ruby 3.1.

Given the amount of work required, doing so would be a sensible choice for Ruby 2.7 and 3.0 branches.

I will prepare new gem releases 2.1.x (for Ruby 2.7) and 2.2.x (for Ruby 3.0) and attach a patch here for ruby.git to import them.

Updated by rhenium (Kazuki Yamaguchi) 11 days ago

  • Status changed from Open to Third Party's Issue

openssl gem version 2.1.3 and 2.2.1 have been released with this change in addition to other bug fixes/improvements.

Backport to ruby core is requested in [Bug #18251] and [Bug #18252].

Actions

Also available in: Atom PDF