Project

General

Profile

Actions

Bug #18268

closed

Behavior change when `each_cons` and `break ... if false` are combined in Ruby 3.1

Added by koic (Koichi ITO) about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 3.1.0dev (2021-10-26T00:30:42Z master 7d4c59203f) [x86_64-darwin19]
[ruby-core:105798]

Description

I'm not sure the details, but the following behavior has changed between Ruby 3.0.2 (and earlier) and Ruby 3.1.0-dev.

# example.rb
def foo
  [1, 2].each_cons(2) do |one, two|
    break one if false
  end
end

p foo

Expected Behavior (Ruby 3.0.2)

It returns nil.

% rbenv local 3.0.2
% ruby -v
ruby 3.0.2p107 (2021-07-07 revision 0db68f0233) [x86_64-darwin19]
% ruby example.rb
nil

Actual Behavior (Ruby 3.1.0-dev)

It returns [1, 2].

% rbenv local 3.1.0-dev
% ruby -v
ruby 3.1.0dev (2021-10-26T00:30:42Z master 7d4c59203f) [x86_64-darwin19]
% ruby example.rb
[1, 2]

I encountered this issue with the following RuboCop build error.
https://app.circleci.com/pipelines/github/rubocop/rubocop/5414/workflows/4a7e4b81-7380-41e5-8ede-e28d9160010d/jobs/201236

The code I encountered is below.
https://github.com/rubocop/rubocop/blob/v1.22.2/lib/rubocop/cop/layout/block_alignment.rb#L104-L106

Updated by osyo (manga osyo) about 1 month ago

It appears to have been changed at https://github.com/ruby/ruby/pull/1509.

Updated by koic (Koichi ITO) about 1 month ago

Thank you for the information source. This looks like a breaking change in Ruby 3.1, but it's okay if it's a considered impact.

Actions #3

Updated by jeremyevans0 (Jeremy Evans) about 1 month ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF