Project

General

Profile

Actions

Bug #18764

closed

Build Error when Using msys2-mingw64 and Ruby 3.2

Added by nekoyama32767 (Jinsong Yu) 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:108484]

Description

There is no problem when use same build-system to build branch ruby_3_1 (commit: e87640cd9d3dfe2cad004224eb356ee406865c8a) and before.

Error describe:
Ruby version:
Ruby master commit: df0bcb3385746e010e100dfb4e66a25dddc2c8fd
Error message:

D:/ruby-git/git/tool/extlibs.rb:6:in `require': cannot load such file -- digest (LoadError)
        from D:/ruby-git/git/tool/extlibs.rb:6:in `<top (required)>'
        from D:/ruby-git/git/ext/psych/extconf.rb:24:in `require_relative'
        from D:/ruby-git/git/ext/psych/extconf.rb:24:in `<top (required)>'
        from ./ext/extmk.rb:217:in `load'
        from ./ext/extmk.rb:217:in `block in extmake'
        from D:/ruby-git/git/lib/mkmf.rb:324:in `open'
        from ./ext/extmk.rb:213:in `extmake'
        from ./ext/extmk.rb:577:in `block in <main>'
        from ./ext/extmk.rb:573:in `each'
        from ./ext/extmk.rb:573:in `<main>'
make[1]: *** [ext/configure-ext.mk:105: ext/psych/exts.mk] Error 1
make[1]: Leaving directory '/d/ruby-git/git'
make: *** [uncommon.mk:289: exts.mk] Error 2

Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #18790: cannot load such file -- digest (LoadError)Closedhsbt (Hiroshi SHIBATA)Actions

Updated by nekoyama32767 (Jinsong Yu) 9 months ago

gcc version: gcc.exe (Rev1, Built by MSYS2 project) 11.2.0

Actions #2

Updated by nekoyama32767 (Jinsong Yu) 9 months ago

  • Description updated (diff)
Actions #3

Updated by nekoyama32767 (Jinsong Yu) 9 months ago

  • Description updated (diff)
Actions #4

Updated by jeremyevans0 (Jeremy Evans) 8 months ago

  • Is duplicate of Bug #18790: cannot load such file -- digest (LoadError) added
Actions #5

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Status changed from Open to Closed

The download feature for libyaml and libffi with extlibs has been removed from Ruby 3.2.0-preview2.

This issue no longer happened.

Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0