Project

General

Profile

Actions

Bug #20581

closed

Ruby 3.3.3 install has missing deps for bundled net-pop gem

Added by MatzFan (Brian Cohen) 29 days ago. Updated 5 days ago.

Status:
Closed
Target version:
-
ruby -v:
ruby 3.3.3 (2024-06-12 revision f1c7b6f435) [x86_64-linux]
[ruby-core:118320]

Description

A stackoverflow question and answer has identified an issue with the Ruby 3.3.3 install which can cause a failure when bundler installs gem dependencies.

https://stackoverflow.com/a/78620570/4114896

A workaround has been described.

There is a related issue with the net-pop gem here: https://github.com/ruby/net-pop/issues/26

Updated by hsbt (Hiroshi SHIBATA) 29 days ago

  • Status changed from Open to Assigned
  • Assignee set to hsbt (Hiroshi SHIBATA)

Updated by hsbt (Hiroshi SHIBATA) 26 days ago

  • Status changed from Assigned to Closed
  • Backport changed from 3.1: UNKNOWN, 3.2: UNKNOWN, 3.3: UNKNOWN to 3.1: DONTNEED, 3.2: UNKNOWN, 3.3: REQUIRED

Thank you for your report. This issue caused by https://github.com/ruby/ruby/commit/0a0338b06fcc3690346d5a3bec60bbcee85ec7ce

Background: This commit truncate default gems if bundled gems used them. But we need to apply prepared commits before this truncation.

The diff of installation results with https://github.com/ruby/ruby/pull/11006 is here(3.3-debug-2 is applied version):

diff --color=auto -ru 3.3-debug/lib/ruby/gems/3.3.0/specifications/net-ftp-0.3.4.gemspec 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/net-ftp-0.3.4.gemspec
--- 3.3-debug/lib/ruby/gems/3.3.0/specifications/net-ftp-0.3.4.gemspec  2024-06-17 14:48:46
+++ 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/net-ftp-0.3.4.gemspec        2024-06-17 14:51:22
@@ -15,8 +15,13 @@
   s.homepage = "https://github.com/ruby/net-ftp".freeze
   s.licenses = ["Ruby".freeze, "BSD-2-Clause".freeze]
   s.required_ruby_version = Gem::Requirement.new(">= 2.6.0".freeze)
-  s.rubygems_version = "3.3.5".freeze
+  s.rubygems_version = "3.5.11".freeze
   s.summary = "Support for the File Transfer Protocol.".freeze

   s.installed_by_version = "3.5.11".freeze if s.respond_to? :installed_by_version
+
+  s.specification_version = 4
+
+  s.add_runtime_dependency(%q<net-protocol>.freeze, [">= 0".freeze])
+  s.add_runtime_dependency(%q<time>.freeze, [">= 0".freeze])
 end
diff --color=auto -ru 3.3-debug/lib/ruby/gems/3.3.0/specifications/net-imap-0.4.9.1.gemspec 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/net-imap-0.4.9.1.gemspec
--- 3.3-debug/lib/ruby/gems/3.3.0/specifications/net-imap-0.4.9.1.gemspec       2024-06-17 14:48:46
+++ 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/net-imap-0.4.9.1.gemspec     2024-06-17 14:51:22
@@ -16,13 +16,15 @@
   s.homepage = "https://github.com/ruby/net-imap".freeze
   s.licenses = ["Ruby".freeze, "BSD-2-Clause".freeze]
   s.required_ruby_version = Gem::Requirement.new(">= 2.7.3".freeze)
-  s.rubygems_version = "3.3.5".freeze
+  s.rubygems_version = "3.5.11".freeze
   s.summary = "Ruby client api for Internet Message Access Protocol".freeze

   s.installed_by_version = "3.5.11".freeze if s.respond_to? :installed_by_version

   s.specification_version = 4

+  s.add_runtime_dependency(%q<net-protocol>.freeze, [">= 0".freeze])
   s.add_runtime_dependency(%q<date>.freeze, [">= 0".freeze])
   s.add_development_dependency(%q<digest>.freeze, [">= 0".freeze])
+  s.add_development_dependency(%q<strscan>.freeze, [">= 0".freeze])
 end
diff --color=auto -ru 3.3-debug/lib/ruby/gems/3.3.0/specifications/net-pop-0.1.2.gemspec 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/net-pop-0.1.2.gemspec
--- 3.3-debug/lib/ruby/gems/3.3.0/specifications/net-pop-0.1.2.gemspec  2024-06-17 14:48:46
+++ 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/net-pop-0.1.2.gemspec        2024-06-17 14:51:22
@@ -15,8 +15,12 @@
   s.email = ["matz@ruby-lang.org".freeze]
   s.homepage = "https://github.com/ruby/net-pop".freeze
   s.licenses = ["Ruby".freeze, "BSD-2-Clause".freeze]
-  s.rubygems_version = "3.3.5".freeze
+  s.rubygems_version = "3.5.11".freeze
   s.summary = "Ruby client library for POP3.".freeze

   s.installed_by_version = "3.5.11".freeze if s.respond_to? :installed_by_version
+
+  s.specification_version = 4
+
+  s.add_runtime_dependency(%q<net-protocol>.freeze, [">= 0".freeze])
 end
diff --color=auto -ru 3.3-debug/lib/ruby/gems/3.3.0/specifications/prime-0.1.2.gemspec 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/prime-0.1.2.gemspec
--- 3.3-debug/lib/ruby/gems/3.3.0/specifications/prime-0.1.2.gemspec    2024-06-17 14:48:46
+++ 3.3-debug-2/lib/ruby/gems/3.3.0/specifications/prime-0.1.2.gemspec  2024-06-17 14:51:22
@@ -15,8 +15,13 @@
   s.homepage = "https://github.com/ruby/prime".freeze
   s.licenses = ["Ruby".freeze, "BSD-2-Clause".freeze]
   s.required_ruby_version = Gem::Requirement.new(">= 2.5.0".freeze)
-  s.rubygems_version = "3.3.5".freeze
+  s.rubygems_version = "3.5.11".freeze
   s.summary = "Prime numbers and factorization library.".freeze

   s.installed_by_version = "3.5.11".freeze if s.respond_to? :installed_by_version
+
+  s.specification_version = 4
+
+  s.add_runtime_dependency(%q<singleton>.freeze, [">= 0".freeze])
+  s.add_runtime_dependency(%q<forwardable>.freeze, [">= 0".freeze])
 end
Actions #3

Updated by hsbt (Hiroshi SHIBATA) 24 days ago

  • Backport changed from 3.1: DONTNEED, 3.2: UNKNOWN, 3.3: REQUIRED to 3.1: DONTNEED, 3.2: DONTNEED, 3.3: REQUIRED

Updated by k0kubun (Takashi Kokubun) 5 days ago

  • Backport changed from 3.1: DONTNEED, 3.2: DONTNEED, 3.3: REQUIRED to 3.1: DONTNEED, 3.2: DONTNEED, 3.3: DONE
Actions

Also available in: Atom PDF

Like1
Like0Like0Like0Like0