Project

General

Profile

Actions

Bug #20591

open

macOS head - all are using OpenSSL 1.1.1?

Added by MSP-Greg (Greg L) 22 days ago.

Status:
Open
Assignee:
-
Target version:
-
[ruby-core:118372]

Description

Currently, the macos.yml file used for GHA CI is using OpenSSL 1.1.1, and the same for the builds done in https://github.com/ruby/ruby-dev-builder.

But, all the macOS builds of 3.1 thru 3.3 are using OpenSSL 3.x?

See the 'Ruby Info' step in any of the macOS builds at https://github.com/MSP-Greg/github-actions-ruby-info/actions/runs/9583386691.

I checked in a fork branch, and the macos.yml CI passes with OpenSSL@3.

Additionally, no macos-14 jobs are being run, just macos-12 & macos-13.

No data to display

Actions

Also available in: Atom PDF

Like0