Bug #3214

Missing function name in "Wrong number of arguments" exception backtrace

Added by Evgeniy Dolzhenko almost 5 years ago. Updated almost 4 years ago.

[ruby-core:29839]
Status:Closed
Priority:Normal
Assignee:-
ruby -v:ruby 1.9.2dev (2010-04-28 trunk 27532) Backport:

Description

=begin
As illustrated below 1.8 reported the name of function called with wrong number of arguments, while 1.9 doesn't

ruby -v -e 'def f(a) end; f'
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-linux]
-e:1:in `f': wrong number of arguments (0 for 1) (ArgumentError)
from -e:1

ruby -v -e 'def f(a) end; f'
ruby 1.9.2dev (2010-04-28 trunk 27532) [i686-linux]
-e:1:in `': wrong number of arguments (0 for 1) (ArgumentError)
=end

History

#1 Updated by Aaron Patterson over 4 years ago

  • Status changed from Open to Closed

=begin
I can't reproduce this on trunk, so I'm closing it.

[apatterson@ypcmc08885 ruby (trunk)]$ ruby -v -e 'def f(a) end; f'
ruby 1.9.3dev (2010-07-15 trunk 28645) [x86_64-darwin10.3.1]
-e:1:in f': wrong number of arguments (0 for 1) (ArgumentError)
from -e:1:in
'
[apatterson@ypcmc08885 ruby (trunk)]$
=end

Also available in: Atom PDF