Project

General

Profile

Bug #3281

fail to build fiddle on Debian/lenny by default

Added by mame (Yusuke Endoh) over 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3dev (2010-05-12 trunk 27758) [i686-linux]
Backport:
[ruby-core:30182]

Description

=begin
Hi Aaron --

fiddle cannot be built on Debian/lenny by default, because extconf.rb
fails to find ffi.h. It can be built by specifying the path:

./configure --with-libffi-include=/usr/include/i486-linux-gnu

But I think it should be built by default on Debian/lenny because it
is the supported platform.

The following patch works for me, but I don't know whether it works
on other platforms.

diff --git a/ext/fiddle/extconf.rb b/ext/fiddle/extconf.rb
index 87c5c9e..9e5536d 100644
--- a/ext/fiddle/extconf.rb
+++ b/ext/fiddle/extconf.rb
@@ -2,7 +2,7 @@ require 'mkmf'

# :stopdoc:

-dir_config 'libffi'
+dir_config 'libffi', "/usr/include/i486-linux-gnu", "/usr/lib"

unless have_header('ffi.h')
if have_header('ffi/ffi.h')

--
Yusuke Endoh mame@tsg.ne.jp
=end

History

#1

Updated by mame (Yusuke Endoh) over 9 years ago

  • Status changed from Open to Rejected

=begin
Hi,

2010/5/12 Tanaka Akira akr@fsij.org:

I can build fiddle on Debian GNU/Linux (lenny) by default.  Strange.

No such configure argument required for me.

Ah, my apologies! I remember that I'm using gcc build from source.
It works well with gcc of Debian package.

Sorry for noise.

--
Yusuke Endoh mame@tsg.ne.jp
=end

Also available in: Atom PDF