Bug #4031

configure: $NM is empty, causing "command not found"

Added by Benoit Daloze over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Nobuyoshi Nakada
ruby -v:ruby 1.9.3dev (2010-11-06 trunk 29706) [x86_64-darwin10.4.0] Backport:

Description

=begin
Running autoconf (2.61), and then ./configure result in an error (ignored):

"./configure: line 39432: conftest.o: command not found"

This come from nobu's commit from yesterday
29706: (configure.in (rb_cv_export_prefix): check for prefixed underscore of exported symbols)
but seems to be a deeper issue, because the error is caused by $NM not being defined or empty at that time.

I searched around, and apparently the 'fi' at line 5324 of the generated configure does not match any 'if', but I could not look further as a 41688-lines generated file is hard to read.

Maybe this issue is from autoconf, I do not see any reason why it would not find my nm at /usr/bin/nm.

I join the configure executable generated.
=end

configure (1 MB) Benoit Daloze, 11/07/2010 05:38 AM

Associated revisions

Revision 29710
Added by Nobuyoshi Nakada over 4 years ago

  • configure.in (NM): check on all platforms. #4031

Revision 29710
Added by Nobuyoshi Nakada over 4 years ago

  • configure.in (NM): check on all platforms. #4031

Revision 29712
Added by Nobuyoshi Nakada over 4 years ago

  • configure.in: check only the first symbol to get rid of duplication. #4031

Revision 29712
Added by Nobuyoshi Nakada over 4 years ago

  • configure.in: check only the first symbol to get rid of duplication. #4031

History

#1 Updated by Nobuyoshi Nakada over 4 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r29710.
Benoit, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

#2 Updated by Benoit Daloze over 4 years ago

=begin
Now I see:
configure: WARNING: Cache variable rb_cv_export_prefix contains a newline.

Is that expected?
=end

#3 Updated by Nobuyoshi Nakada over 4 years ago

=begin
I don't see it, on both of darwin and linux.
What's the result of the following command?

$ grep -A1 export_prefix config.cache

Try with removing the rb_cv_export_prefix line from config.cache file, or removing the cache file itself.
=end

#4 Updated by Benoit Daloze over 4 years ago

=begin

$ grep -A1 export_prefix config.cache
I do not have any config.cache

However, config.log match (and is the only, except configure and configure.in):
configure:40468: WARNING: Cache variable rb_cv_export_prefix contains a newline.
configure:40571: creating ./config.status
--
configure:41710: WARNING: Cache variable rb_cv_export_prefix contains a newline.
ac_cv_build=x86_64-apple-darwin10.4.0

I deleted the config.status, but nothing changed, even when restarting from zero (rm, autoconf, ./configure)

I still have it at every ./configure

The value of rb_cv_export_prefix seems to be:
_
_
(two underscores with a \n between)
=end

Also available in: Atom PDF