Bug #5476

ruby 1.9.3_rc1 segfaults in test_fork.rb on HPPA

Added by Hans de Graaff over 2 years ago. Updated over 1 year ago.

[ruby-core:40306]
Status:Closed
Priority:Normal
Assignee:-
Category:test
Target version:1.9.3
ruby -v:1.9.3_rc1 Backport:

Description

Running tests on HPPA results in a segmentation fault when running test_fork.rb.

The downstream bug report at https://bugs.gentoo.org/show_bug.cgi?id=388123 has all the details and the full build log.

#246 test_fork.rb:24:in <top (required)>':
Process.setrlimit(:NPROC, 1)
fork {}
#=> killed by SIGABRT (signal 6)
| bootstraptest.tmp.rb:3: [BUG] Segmentation fault
| ruby 1.9.3dev (2011-09-23 revision 33323) [hppa-linux]
|
| -- Control frame information -----------------------------------------------
| c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :fork
| c:0003 p:0048 s:0007 b:0006 l:000cd4 d:000d2c EVAL bootstraptest.tmp.rb:3
| c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
| c:0001 p:0000 s:0002 b:0002 l:000cd4 d:000cd4 TOP
|
| -- Ruby level backtrace information ----------------------------------------
| bootstraptest.tmp.rb:3:in
'
| bootstraptest.tmp.rb:3:in `fork'

[...]

History

#1 Updated by Motohiro KOSAKI over 2 years ago

Please give me C level backtrace.

#2 Updated by Lucas Nussbaum over 2 years ago

Ruby on hppa is broken because hppa (at least last time I checked) was using a LinuxThreads-based thread implementation instead of NPTL.

Maybe it should not crash, but I don't expect that you will reach a working state anyway.

#3 Updated by Shota Fukumori over 2 years ago

  • Status changed from Open to Feedback

#4 Updated by Hans de Graaff over 2 years ago

Lucas Nussbaum wrote:

Ruby on hppa is broken because hppa (at least last time I checked) was using a LinuxThreads-based thread implementation instead of NPTL.

Not true at least on Gentoo/HPPA which has been using NPTL. So at least that is not a hurdle. I'll have to check for the backtrace, I can't produce one myself.

#5 Updated by Hans de Graaff over 1 year ago

It looks like this got fixed with http://bugs.ruby-lang.org/issues/5488, we can no longer reproduce this in the latest version of ruby 1.9.3.

#6 Updated by Motohiro KOSAKI over 1 year ago

  • Status changed from Feedback to Closed

OK, thank you.

Also available in: Atom PDF