Bug #6025

IRB test: failure caused by non-guarded completion test

Added by Luis Lavena about 2 years ago. Updated about 2 years ago.

[ruby-core:42632]
Status:Closed
Priority:Normal
Assignee:Usaku NAKAMURA
Category:test
Target version:1.9.3
ruby -v:ruby 1.9.3p105 (2012-02-13 revision 34579) [i386-mingw32] Backport:

Description

Hello,

While testing for 1.9.3-p105 release, found the following test fail:

65) Failure:
testnonstringmodulename(TestIRB::TestCompletion) [C:/Users/Luis/Projects/oss/ruby/test/irb/testcompletion.rb:13]:
.
<[]> expected but was
<["C:/Users/Luis/Projects/oss/ruby/lib/rubygems/customrequire.rb:36:in require': cannot load such
file -- readline (LoadError)",
"\tfrom C:/Users/Luis/Projects/oss/ruby/lib/rubygems/custom_require.rb:36:in
require'",
"\tfrom C:/Users/Luis/Projects/oss/ruby/lib/irb/completion.rb:9:in <top (required)>'",
"\tfrom C:/Users/Luis/Projects/oss/ruby/lib/rubygems/custom_require.rb:36:in
require'",
"\tfrom C:/Users/Luis/Projects/oss/ruby/lib/rubygems/custom
require.rb:36:in `require'"]>.

RubyInstaller builds do not include GNU Readline and instead uses rb-readline replacement.

It fails to load it's replacement and because of that, fails to load and complete the test.

A guard against it perhaps needs to be implemented.

Ruby 1.9.3-p0 did not present this failure.

Thank you

History

#1 Updated by Usaku NAKAMURA about 2 years ago

  • Status changed from Open to Closed
  • Assignee set to Usaku NAKAMURA

already fixed at r34591.

Also available in: Atom PDF