Bug #6334

64 bit build broken for 1.9.3 on Solaris 10 and openindiana - test_fork.rb

Added by Colin Ellis almost 2 years ago. Updated over 1 year ago.

[ruby-core:44507]
Status:Rejected
Priority:Low
Assignee:Naohisa Goto
Category:-
Target version:-
ruby -v:ruby 1.9.3p195 (2012-04-20 revision 32371) [i386-solaris2.10] Backport:

Description

make test fails with:

#248 test_fork.rb:51:in `': core dumped [Ruby 1.9 - Bug #4950]
FAIL 1/943 tests failed
gmake: *** [yes-btest-ruby] Error 1

No coredump is actually produced.

Operating System: Solaris 10 x86
Compiler: GCC 4.4.5

To reproduce:
./configure CFLAGS="-m64" && gmake test

Seems that r32562 broke it. If I revert that changeset All tests pass as expected.

History

#1 Updated by Yui NARUSE almost 2 years ago

  • Status changed from Open to Assigned
  • Assignee set to Nobuyoshi Nakada

#2 Updated by Naohisa Goto almost 2 years ago

  • Status changed from Assigned to Feedback

Please show full build log with
./configure CFLAGS="-m64" && gmake V=1 test

In Solaris, more and more options may be needed for 64-bit compile.

The r32562 fixes that "-m64" was always removed from CFLAGS.
Without r32562, the "-m64" is removed and 32-bit binaries is always generated. Please check the binaries by using "file" command.

#3 Updated by Colin Ellis almost 2 years ago

My testing method is flawed. I am going back and re-doing to find out when things broke.

Somewhere between r192 and r193 a change has caused 64 bit builds to fail in test_fork.rb. I thought I had it but jumped too soon :)

I'll update as soon as I have something useful.

#4 Updated by Naohisa Goto over 1 year ago

  • Status changed from Feedback to Rejected
  • Assignee changed from Nobuyoshi Nakada to Naohisa Goto
  • Priority changed from Normal to Low

Closing because of no feedback.
Please reopen the ticket with detailed information if you still have the problem.

Also available in: Atom PDF