Project

General

Profile

Bug #6355

arm-linux build test suite fails: on : /lib/ruby/1.9.1/arm-linux/digest/md5.so: [BUG] Segmentation fault

Added by stevegoobermanhill (stephen gooberman-hill) over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.2p136 (2010-12-25 revision 30365) [arm-linux]
Backport:
[ruby-core:44619]

Description

build test suite fails

  • first claims that a file which exists is not found
  • then throws a segfault

I suspect that this may be an issue with the test suite as if I run the test on it's own, ruby claims that the file cannot be found and exits cleanly with a LoadError. Still, I'm not sure that ruby should segfault.

Kind regards

Steve

[root@techbase /mnt/nand-user/ruby-1.9.2-p136]# ls /lib/ruby/1.9.1/arm-linux/digest
bubblebabble.so md5.so rmd160.so sha1.so sha2.so

[root@techbase /mnt/nand-user/ruby-1.9.2-p136]# /mnt/nand-user/ruby/bin/ruby test/runner.rb
/mnt/nand-user/ruby-1.9.2-p136/test/xmlrpc/test_webrick_server.rb: File not found - /lib/ruby/1.9.1/arm-linux/digest/md5.so
/lib/ruby/1.9.1/arm-linux/digest/md5.so: [BUG] Segmentation fault
ruby 1.9.2p136 (2010-12-25 revision 30365) [arm-linux]

-- control frame ----------
c:0026 p:-2048474 s:0090 b:0090 l:000089 d:000089 TOP

c:0025 p:---- s:0088 b:0088 l:000087 d:000087 CFUNC :require
c:0024 p:0013 s:0084 b:0084 l:000083 d:000083 METHOD internal:lib/rubygems/custom_require:29
c:0023 p:0047 s:0079 b:0079 l:000078 d:000078 TOP /lib/ruby/1.9.1/webrick/httpauth/digestauth.rb:17
c:0022 p:---- s:0077 b:0077 l:000076 d:000076 FINISH
c:0021 p:---- s:0075 b:0075 l:000074 d:000074 CFUNC :require
c:0020 p:0013 s:0071 b:0071 l:000070 d:000070 METHOD internal:lib/rubygems/custom_require:29
c:0019 p:0023 s:0066 b:0066 l:000065 d:000065 TOP /lib/ruby/1.9.1/webrick/httpauth.rb:12
c:0018 p:---- s:0064 b:0064 l:000063 d:000063 FINISH
c:0017 p:---- s:0062 b:0062 l:000061 d:000061 CFUNC :require
c:0016 p:0013 s:0058 b:0058 l:000057 d:000057 METHOD internal:lib/rubygems/custom_require:29
c:0015 p:0203 s:0053 b:0053 l:000052 d:000052 TOP /lib/ruby/1.9.1/webrick.rb:29
c:0014 p:---- s:0051 b:0051 l:000050 d:000050 FINISH
c:0013 p:---- s:0049 b:0049 l:000048 d:000048 CFUNC :require
c:0012 p:0013 s:0045 b:0045 l:000044 d:000044 METHOD internal:lib/rubygems/custom_require:29
c:0011 p:0035 s:0040 b:0040 l:000039 d:000039 TOP /mnt/nand-user/ruby-1.9.2-p136/test/xmlrpc/test_cookie.rb:3
c:0010 p:---- s:0038 b:0038 l:000037 d:000037 FINISH
c:0009 p:---- s:0036 b:0036 l:000035 d:000035 CFUNC :require
c:0008 p:0013 s:0032 b:0032 l:000031 d:000031 METHOD internal:lib/rubygems/custom_require:29
c:0007 p:0077 s:0027 b:0027 l:000016 d:000026 BLOCK /lib/ruby/1.9.1/test/unit.rb:55
c:0006 p:---- s:0022 b:0022 l:000021 d:000021 FINISH
c:0005 p:---- s:0020 b:0020 l:000019 d:000019 CFUNC :each
c:0004 p:0290 s:0017 b:0017 l:000016 d:000016 METHOD /lib/ruby/1.9.1/test/unit.rb:49
c:0003 p:0114 s:0008 b:0008 l:001d1c d:00009c EVAL test/runner.rb:9
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH

c:0001 p:0000 s:0002 b:0002 l:001d1c d:001d1c TOP

-- Ruby level backtrace information ----------------------------------------
test/runner.rb:9:in <main>'
/lib/ruby/1.9.1/test/unit.rb:49:in
setup_argv'
/lib/ruby/1.9.1/test/unit.rb:49:in each'
/lib/ruby/1.9.1/test/unit.rb:55:in
block in setup_argv'
internal:lib/rubygems/custom_require:29:in require'
<internal:lib/rubygems/custom_require>:29:in
require'
/mnt/nand-user/ruby-1.9.2-p136/test/xmlrpc/test_cookie.rb:3:in <top (required)>'
<internal:lib/rubygems/custom_require>:29:in
require'
internal:lib/rubygems/custom_require:29:in require'
/lib/ruby/1.9.1/webrick.rb:29:in
'
internal:lib/rubygems/custom_require:29:in require'
<internal:lib/rubygems/custom_require>:29:in
require'
/lib/ruby/1.9.1/webrick/httpauth.rb:12:in <top (required)>'
<internal:lib/rubygems/custom_require>:29:in
require'
internal:lib/rubygems/custom_require:29:in require'
/lib/ruby/1.9.1/webrick/httpauth/digestauth.rb:17:in
'
internal:lib/rubygems/custom_require:29:in require'
<internal:lib/rubygems/custom_require>:29:in
require'

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.

History

Updated by mame (Yusuke Endoh) over 7 years ago

  • Status changed from Open to Feedback

At first, please try Ruby trunk.

If the problem still occurs, could you please create a patch yourself?
There is no arm maintainer unfortunately.

If your patch looks simple and benign for other platforms, we may import it.

Thanks,

--
Yusuke Endoh mame@tsg.ne.jp

Updated by stevegoobermanhill (stephen gooberman-hill) over 7 years ago

Yusuke-san
Please close - identified as a missing linux library dependency.

The following script finds missing library dependencies

#!ruby

lib_list=find . -name *.so.split("\n")
lib_list.each do |lib|
ldd_out=ldd #{lib}
missing=ldd_out.split("\n").collect{|x| x=~/=> not found/? x : nil }
missing.compact!
puts lib unless missing.empty?
missing.each{|x| puts ' '+x}
end

kind regards,
Steve

Updated by mame (Yusuke Endoh) about 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF