Project

General

Profile

Bug #6484

Segmentation fault using thin on Windows 7

Added by Christoph Hannebauer about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.9.3p194 (2012-04-20) [i386-mingw32]
[ruby-core:45199]

Description

After cloning the git project git.js from https://github.com/danlucraft/git.js and executing rake demo, I receive a Segmentation fault. The output from stderr is attached as well as the output to the console.

I am using Windows 7, 64 Bit. I installed Ruby using the RubyInstaller 1.9.3-p194 from http://rubyinstaller.org . I have attached a list of gems I have installed. I installed those directly via gem from the server repository except eventmachine. I used the procedure described in http://snippets.aktagon.com/snippets/289-How-to-install-thin-rack-and-eventmachine-on-Windows-Cygwin to install eventmachine:

git clone git://github.com/eventmachine/eventmachine.git
cd eventmachine
rake gem
cd pkg
gem install eventmachine-1.0.0.beta.4

rake-demo-error-output.txt Magnifier - output from stderr (12.8 KB) Christoph Hannebauer, 05/23/2012 05:48 PM

rake-demo-console-output.txt Magnifier - output to console (374 Bytes) Christoph Hannebauer, 05/23/2012 05:48 PM

local-gems.txt Magnifier - List of installed gems (217 Bytes) Christoph Hannebauer, 05/23/2012 05:48 PM

History

#1 [ruby-core:45200] Updated by Hiroshi Shirosaki about 4 years ago

Please see this issue.
https://github.com/eventmachine/eventmachine/issues/319

You will solve it by commenting out line 85 of ext\project.h: #define FD_SETSIZE 1024.

#2 [ruby-core:45201] Updated by Luis Lavena about 4 years ago

  • Status changed from Open to Rejected

This is a duplicate of #6352

Also available in: Atom PDF