Project

General

Profile

Bug #6523

typos/display errors in Regexp.html page

Added by nathanst (Nathan Stratton Treadway) over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
9.1.3
[ruby-core:45348]

Description

I was looking through the Regexp class documentation found at
http://www.ruby-doc.org/core-1.9.3/Regexp.html
... and found a number of problems that appeared to be either display issues or typos.

Most notably, throughout the entire document the { characters at the start of the %{...} contruct are missing. In many cases the closing } character is missing, too; in some cases it appears that a closing / character is used in the example, even though the RE was started with "%r".

Needly to say, this makes understanding the examples rather difficult....

Possibly related to the same issue, in the example definition of the float_pat expression found in the "Free-Spacing Mode and Comments", I don't see the "x" option actually specified anywhere in the example code....

In the "Performance" section of the page, there is a somewhat different type of issue: in the "Match a string of 29 as against a pattern of 29 optional" example, I don't see any actual call to .match() (though one does appear in the the next example down).

I checked the page in several versions of Firefox and also Safari, so I don't believe the issues are related to a specific browser.

Thanks.

Nathan


Related issues

Is duplicate of Ruby trunk - Bug #6488: String#slice example has a syntax errorClosed2012-05-24

History

#1 [ruby-core:45350] Updated by drbrain (Eric Hodel) over 5 years ago

  • Category set to lib
  • Status changed from Open to Closed
  • Assignee set to drbrain (Eric Hodel)

This is a duplicate of #6488

Also available in: Atom PDF