Project

General

Profile

Bug #6978

RDoc does not convert <Ruby_element>@<paragraph_name> to hyperlinks

Added by Lavir the Whiolet over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
ruby -v:
ruby 2.0.0dev (2012-09-02 trunk 36881) [x86_64-linux]
Backport:
2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
[ruby-core:47419]

Description

With attached "test.rb" I issue command "rdoc test.rb" and gets some HTML doc. In the HTML doc I expect to see "Test@Some+Paragraph" replaced with a hyperlink with text "Some Paragraph at Test" and reference to "Some Paragraph" paragraph near Test class. But I only see "Test@Some+Paragraph" text in the HTML doc.

test.rb Magnifier (193 Bytes) Lavir the Whiolet, 09/04/2012 06:44 PM

History

#1 [ruby-core:47424] Updated by Eric Hodel over 3 years ago

  • Category set to lib
  • Status changed from Open to Assigned
  • Assignee set to Eric Hodel

#2 [ruby-core:49542] Updated by Eric Hodel about 3 years ago

  • Status changed from Assigned to Closed

I can't reproduce the failure with rdoc master. I believe it is fixed.

Also available in: Atom PDF