Bug #7623

Messages while RDoc generation

Added by Tomoaki Nishiyama over 1 year ago. Updated about 1 year ago.

[ruby-core:51126]
Status:Closed
Priority:Normal
Assignee:Eric Hodel
Category:doc
Target version:2.0.0
ruby -v:ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-linux] Backport:

Description

The message reported in
https://bugs.ruby-lang.org/issues/5366
happened during compilation of the ruby-1.9.3-p327.tar.bz2 distribution on CentOS6.
While the message was observed just by extract, configure and make,
make clean just after configure did not help either.

uname -a
Linux xxxx 2.6.32-279.14.1.el6.x8664 #1 SMP Tue Nov 6 23:43:09 UTC 2012 x8664 x8664 x8664 GNU/Linux

steps to reproduce
$ tar jxvf ruby-1.9.3-p327.tar.bz2
$ cd ruby-1.9.3-p327
$ ./configure --prefix=$HOME/local
$ make
...
Generating RDoc documentation
Parsing sources...
lib/mkmf.rb:1117:29: Couldn't find STRINGORFAILEDFORMAT. Assuming it's a module
lib/irb/inspector.rb:36:36: Couldn't find INSPECTORS. Assuming it's a module

Enclosing class/module 'mDigest' for class MD5 not known

Enclosing class/module 'mDigest' for class RMD160 not known

Enclosing class/module 'mDigest' for class SHA1 not known

Enclosing class/module "cASN1ObjectId" for alias short
name sn not known

Enclosing class/module "cASN1ObjectId" for alias long_name ln not known
100% [773/773] doc/re.rdoc

These messages are unclear if they are normal notification/warnings
that may be ignored, or error messages that should be taken care of.
make test reported no error.

If this is not a bad indicator, some explanation in document is desired.

make; make clean; make
sequence have not solved problem, but
generated the following error:

configuring zlib
make[1]: Entering directory /home/tomoaki/ruby-1.9.3-p327'
make[2]: Entering directory
/home/tomoaki/ruby-1.9.3-p327/ext/-test-/array/resize'
compiling resize.c
linking shared-object -test-/array/resize.so
/usr/bin/ld: cannot open output file ../../../../.ext/x8664-linux/-test-/array/resize.so: No such file or directory
collect2: ld returned 1 exit status
make[2]: *** [../../../../.ext/x86
64-linux/-test-/array/resize.so] Error 1
make[2]: Leaving directory /home/tomoaki/ruby-1.9.3-p327/ext/-test-/array/resize'
make[1]: *** [ext/-test-/array/resize/all] Error 2
make[1]: Leaving directory
/home/tomoaki/ruby-1.9.3-p327'
make: *** [build-ext] Error 2

This is apparently another problem, which need not be handled in normal installation.
But suggests that make clean fails to delete something that should be deleted or
insufficient information is described in the Makefile.

History

#1 Updated by Zachary Scott over 1 year ago

  • Status changed from Open to Closed

duplicate of #7550

#2 Updated by Tomoaki Nishiyama over 1 year ago

Thank you for looking at my report.
My point is on the messages:

lib/mkmf.rb:1117:29: Couldn't find STRINGORFAILEDFORMAT. Assuming it's a module
lib/irb/inspector.rb:36:36: Couldn't find INSPECTORS. Assuming it's a module
Enclosing class/module 'mDigest' for class MD5 not known
Enclosing class/module 'mDigest' for class RMD160 not known
Enclosing class/module 'mDigest' for class SHA1 not known
Enclosing class/module "cASN1ObjectId" for alias short
name sn not known
Enclosing class/module "cASN1ObjectId" for alias long_name ln not known

make after make clean was just to test if the above message disappear after one round of make.
The make after make clean problem was solved in 1.9.3-p362 but the above message continued.

#3 Updated by Eric Hodel about 1 year ago

  • Assignee set to Eric Hodel
  • Target version set to 2.0.0
  • % Done changed from 0 to 100

=begin
These messages have all been fixed:

Generating RDoc documentation
Parsing sources...
100% [873/873] /Users/drbrain/Work/svn/ruby/trunk/vsnprintf.c

Generating RI format into /Users/drbrain/Work/svn/ruby/build/.ext/rdoc...

Files: 873

Classes: 1419 ( 0 undocumented)
Modules: 315 ( 7 undocumented)
Constants: 1657 ( 818 undocumented)
Attributes: 1154 ( 399 undocumented)
Methods: 11164 (2840 undocumented)

Total: 15709 (4064 undocumented)
74.13% documented

Elapsed: 119.5s
=end

Also available in: Atom PDF