Project

General

Profile

Bug #7680

IRB autocompletion doesn't autocomplete methods

Added by Zachary Scott over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
[ruby-core:51348]

Description

steps to reproduce:

$ irb
irb(main):001:0> irb_

This returns nothing, but should return all of the irb commands. Such as irb_binding, irb_context, irb_jobs, irb_help, etc etc

Associated revisions

Revision 39048
Added by Zachary Scott about 3 years ago

  • lib/irb.rb, lib/irb/context.rb: Add documentation on how to enable auto-indentation and autocompletion using irbrc and irb_context [Bug #7642] and [Bug #7680]

Revision 39048
Added by Zachary Scott about 3 years ago

  • lib/irb.rb, lib/irb/context.rb: Add documentation on how to enable auto-indentation and autocompletion using irbrc and irb_context [Bug #7642] and [Bug #7680]

Revision 39048
Added by Zachary Scott about 3 years ago

  • lib/irb.rb, lib/irb/context.rb: Add documentation on how to enable auto-indentation and autocompletion using irbrc and irb_context [Bug #7642] and [Bug #7680]

History

#1 [ruby-core:51351] Updated by Zachary Scott over 3 years ago

  • Status changed from Open to Assigned

#2 [ruby-core:51354] Updated by Keiju Ishitsuka over 3 years ago

zzak (Zachary Scott) wrote:

steps to reproduce:

$ irb
irb(main):001:0> irb_

This returns nothing, but should return all of the irb commands. Such as irb_binding, irb_context, irb_jobs, irb_help, etc etc

Please, try:

% irb -r irb/completion
irb(main):001:0> irb_

#3 [ruby-core:51355] Updated by Zachary Scott over 3 years ago

This works, should irb/completion be required by default?

#4 [ruby-core:51360] Updated by Keiju Ishitsuka over 3 years ago

zzak (Zachary Scott) wrote:

This works, should irb/completion be required by default?

Yes.
Otherwise, you can write .irbrc to:

require "irb/completion"

#5 [ruby-core:51362] Updated by Zachary Scott over 3 years ago

Can we make irb default require irb/completion?

I will open up a feature request.

#6 [ruby-core:51361] Updated by Lee Jarvis over 3 years ago

This works, should irb/completion be required by default?

I looks like it never was. Although I don't see any reason for not including this behaviour by default. Maybe depending on readline.

#7 [ruby-core:51382] Updated by Keiju Ishitsuka over 3 years ago

  • Status changed from Assigned to Rejected

zzak (Zachary Scott) wrote:

Can we make irb default require irb/completion?

I will open up a feature request.

Irb completion function is still incomplete.
I might be the default this feature is now more complete.

Also available in: Atom PDF