Project

General

Profile

Bug #7818

Ruby 2.0.0-rc2 is not compatible with openssl 1.0.1d.

Added by agileanimal (Mark Madsen) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-darwin12.3.0]
[ruby-core:52079]

Description

=begin
Ruby 2.0.0-rc2 is not compatible with openssl 1.0.1d.

It works as expected on 1.0.1c

When used with 1.0.1d ruby is unable to validate certificates and other things might be broken as well.

For example:

gem install bundler --source https://rubygems.org

will fail when linked to 1.0.1d with:

ERROR:  While executing gem ... (OpenSSL::SSL::SSLError)
    SSL_read: bad decompression

As noted, openssl 1.0.1c works as expected.
=end

History

#1 [ruby-core:52080] Updated by MartinBosslet (Martin Bosslet) almost 5 years ago

  • Category set to ext
  • Status changed from Open to Assigned
  • Assignee set to MartinBosslet (Martin Bosslet)

#2 [ruby-core:52081] Updated by bitsweat (Jeremy Daer) almost 5 years ago

This is working for me:

2.0.0-rc2 ~ ruby -ropenssl -e 'puts RUBY_DESCRIPTION, OpenSSL::OPENSSL_VERSION'
ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-darwin12.2.0]
OpenSSL 1.0.1d 5 Feb 2013

2.0.0-rc2 ~ gem install bundler --source https://rubygems.org
Successfully installed bundler-1.2.3
Done installing documentation for bundler (0 sec).
1 gem installed

#3 [ruby-core:52083] Updated by agileanimal (Mark Madsen) almost 5 years ago

I was seeing it fail when it tries to validate without a cacert.pem for openssl - but in this case shouldn't it fall back to the pem that comes with ruby gems?

#4 [ruby-core:52084] Updated by agileanimal (Mark Madsen) almost 5 years ago

I am building ruby with 1.0.1d on something that is not a Mac right now and will report back the results.

#5 [ruby-core:52086] Updated by agileanimal (Mark Madsen) almost 5 years ago

@Martin, you can close this. I think the issue is that the openssl 1.0.1d bundled with rbenv couldn't find it's cacert.pem.

#6 [ruby-core:52096] Updated by MartinBosslet (Martin Bosslet) almost 5 years ago

  • Status changed from Assigned to Closed

Alright, closed. Thanks Mark, for sorting this out!

Also available in: Atom PDF