Bug #7943

Can't build from source or snapshots without pre-existing Ruby

Added by Paul Sherwood about 1 year ago. Updated about 1 year ago.

[ruby-core:52822]
Status:Rejected
Priority:Normal
Assignee:-
Category:build
Target version:-
ruby -v:n/a Backport:

Description

On a Linux system with autotools, GCC etc,
but no pre-existing Ruby, make fails for the following snapshots:

http://ftp.ruby-lang.org/pub/ruby/snapshot.tar.gz
http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p392.tar.gz
http://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p0.tar.gz

The error using the 2.0.0-p0 snapshot is

make
CC = gcc
LD = ld
LDSHARED =
CFLAGS =
XCFLAGS = -include ruby/config.h -include ruby/missing.h -DFORTIFYSOURCE=2 -fstack-protector -fno-strict-overflow -fvisibility=hidden -DRUBYEXPORT -fPIE
CPPFLAGS = -I. -I.ext/include/x86
64-linux -I./include -I.
DLDFLAGS = -fstack-protector -pie

SOLIBS =
generating miniprelude.c
executable host ruby is required. use --with-baseruby option.
uncommon.mk:900: recipe for target `miniprelude.c' failed
make: *** [miniprelude.c] Error 1


Related issues

Duplicates Backport200 - Backport #6807: Can't compile ruby without ruby Closed 07/28/2012

History

#1 Updated by Luis Lavena about 1 year ago

  • Status changed from Open to Rejected

Duplicate of #6807, which I just reopened.

Also available in: Atom PDF