Project

General

Profile

Bug #7969

Integer binary_op Float operations doesn't use coercion

Added by Ilya Vorontsov over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
ruby -v:
1.9.3; 2.0.0
[ruby-core:52937]

Description

I'm trying to override #coerce method on Float. But I found that redefining Float#coerce makes no changes in behavior of code: 1 + 2.0
class Float
def coerce(other)
[2, 2]
end
end
puts 1+2.0 # ==> 3.0 while result should be 4.

Is it done due to perfomance considerations or it's just a bug? If it's intended is it a spec or realization specific feature?

History

#1 [ruby-core:52939] Updated by Nobuyoshi Nakada over 3 years ago

  • Status changed from Open to Rejected

Intended behavior.
coerce method is called if the peer is unknown to the receiver.

Also available in: Atom PDF