Bug #7977

rails 4 crashes ruby 2.0 on Solaris

Added by John Groenveld about 2 years ago. Updated over 1 year ago.

[ruby-core:52977]
Status:Rejected
Priority:Normal
Assignee:Naohisa Goto
ruby -v:ruby 2.0.0p0 (2013-02-24 revision 39474) [i386-solaris2.11] Backport:

Description

env PATH=/opt/apache2/ruby-2.0.0/bin:/usr/gnu/bin:/usr/bin:/usr/sbin:/usr/ccs/bin:/opt/solarisstudio12.3/bin:/usr/sfw/bin gem install rails --version 4.0.0.beta1 --no-ri --no-rdoc

/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:951: [BUG] Segmentation fault
ruby 2.0.0p0 (2013-02-24 revision 39474) [i386-solaris2.11]

-- Control frame information -----------------------------------------------
c:0018 p:---- s:0078 e:000077 CFUNC :eval
c:0017 p:0114 s:0072 E:002358 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:951
c:0016 p:0019 s:0065 e:000064 BLOCK /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:628 [FINISH]
c:0015 p:---- s:0061 e:000060 CFUNC :each
c:0014 p:0028 s:0058 e:000057 BLOCK /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:627 [FINISH]
c:0013 p:---- s:0055 e:000054 CFUNC :each
c:0012 p:0008 s:0052 e:000051 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:626
c:0011 p:0012 s:0048 e:000047 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:642
c:0010 p:0035 s:0044 E:0005e0 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:653
c:0009 p:0024 s:0040 e:000039 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:806 [FINISH]
c:0008 p:---- s:0037 e:000036 CFUNC :map
c:0007 p:0045 s:0034 e:000032 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems.rb:418
c:0006 p:0012 s:0027 e:000025 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems.rb:928
c:0005 p:0063 s:0023 e:000022 TOP /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/gem_runner.rb:73 [FINISH]
c:0004 p:---- s:0021 e:000020 CFUNC :require
c:0003 p:0073 s:0017 e:000016 METHOD /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45
c:0002 p:0015 s:0007 E:000180 EVAL /opt/apache2/ruby-2.0.0/bin/gem:9 [FINISH]
c:0001 p:0000 s:0002 E:000a48 TOP [FINISH]

-- Ruby level backtrace information ----------------------------------------
/opt/apache2/ruby-2.0.0/bin/gem:9:in <main>'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
require'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in require'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/gem_runner.rb:73:in
'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems.rb:928:in load_plugins'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems.rb:418:in
find_files'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems.rb:418:in map'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:806:in
each'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:653:in _all'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:642:in
each_normal'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:626:in each_spec'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:626:in
each'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:627:in block in each_spec'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:627:in
each'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:628:in block (2 levels) in each_spec'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:951:in
load'
/opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb:951:in `eval'

-- C level backtrace information -------------------------------------------
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_vm_bugreport+0x63 [0xffff80ffb6005033]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'report_bug+0x116 [0xffff80ffb5ed04c6]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_bug+0xbb [0xffff80ffb5ed05bb]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'sigsegv+0x4e [0xffff80ffb5f8cd0e]
/lib/amd64/libc.so.1'_sighndlr+0x6 [0xffff80ffbf5418b6]
/lib/amd64/libc.so.1'call_user_handler+0x2ce [0xffff80ffbf53503a]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'onigenc_get_prev_char_head+0x24 [0xffff80ffb5f6f6b4]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'ruby_yyparse+0x6f15 [0xffff80ffb5f34255]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'yycompile0+0x156 [0xffff80ffb5f36246]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_suppress_tracing+0xdf [0xffff80ffb600791f]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'yycompile+0x35 [0xffff80ffb5f36345]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'parse_string+0x2c [0xffff80ffb5fe85ac]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_iseq_compile_with_option+0x11f [0xffff80ffb5fe86ff]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'eval_string_with_cref+0x234 [0xffff80ffb5ffdf44]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_f_eval+0x111 [0xffff80ffb5ffe421]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call_cfunc_with_frame+0x348 [0xffff80ffb5ff0c88]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec_core+0x2c7b [0xffff80ffb5ff5d6b]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec+0xb0f [0xffff80ffb60023bf]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'invoke_block_from_c+0x49a [0xffff80ffb6000a9a]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_yield+0x73 [0xffff80ffb5ffcf93]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_ary_each+0x77 [0xffff80ffb5e9d337]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call_cfunc_with_frame+0x348 [0xffff80ffb5ff0c88]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec_core+0x2d09 [0xffff80ffb5ff5df9]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec+0xb0f [0xffff80ffb60023bf]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'invoke_block_from_c+0x49a [0xffff80ffb6000a9a]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_yield+0x73 [0xffff80ffb5ffcf93]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_ary_each+0x77 [0xffff80ffb5e9d337]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm
call_cfunc_with_frame+0x348 [0xffff80ffb5ff0c88]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call_method+0x39b [0xffff80ffb5ff1f3b]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec_core+0x2d09 [0xffff80ffb5ff5df9]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec+0xb0f [0xffff80ffb60023bf]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call0+0x36 [0xffff80ffb5ffa736]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'iterate_method+0xa1 [0xffff80ffb5ffdb41]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_iterate+0x167 [0xffff80ffb5ffd797]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_block_call+0x30 [0xffff80ffb5ffdbc0]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'enum_collect+0x39 [0xffff80ffb5ec81a9]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call_cfunc_with_frame+0x348 [0xffff80ffb5ff0c88]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call_method+0x39b [0xffff80ffb5ff1f3b]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec_core+0x2d09 [0xffff80ffb5ff5df9]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec+0xb0f [0xffff80ffb60023bf]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_load_internal+0x173 [0xffff80ffb5ed93f3]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'rb_require_safe+0x1e5 [0xffff80ffb5ed9f95]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_call_cfunc_with_frame+0x348 [0xffff80ffb5ff0c88]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec_core+0x2c7b [0xffff80ffb5ff5d6b]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'vm_exec+0xb0f [0xffff80ffb60023bf]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'ruby_exec_internal+0x95 [0xffff80ffb5ed52e5]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'ruby_exec_node+0x1e [0xffff80ffb5ed53ee]
/opt/apache2/ruby-2.0.0/lib/libruby.so.2'ruby_run_node+0x24 [0xffff80ffb5ed53b4]
/opt/apache2/ruby-2.0.0/bin/ruby'main+0x4c [0x400f0c]
/opt/apache2/ruby-2.0.0/bin/ruby'0xd5b [0x400d5b]

-- Other runtime information -----------------------------------------------

  • Loaded script: /opt/apache2/ruby-2.0.0/bin/gem

  • Loaded features:

    0 enumerator.so
    1 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/i386-solaris2.11/enc/encdb.so
    2 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/i386-solaris2.11/enc/trans/transdb.so
    3 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/i386-solaris2.11/rbconfig.rb
    4 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/compatibility.rb
    5 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/defaults.rb
    6 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/deprecate.rb
    7 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/errors.rb
    8 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/version.rb
    9 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/requirement.rb
    10 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/platform.rb
    11 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/specification.rb
    12 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/exceptions.rb
    13 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb
    14 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb
    15 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems.rb
    16 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/optparse.rb
    17 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/user_interaction.rb
    18 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/command.rb
    19 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/command_manager.rb
    20 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/i386-solaris2.11/etc.so
    21 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/config_file.rb
    22 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/path_support.rb
    23 /opt/apache2/ruby-2.0.0/lib/ruby/2.0.0/rubygems/dependency.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Abort (core dumped)

pstack core

core 'core' of 404: /opt/apache2/ruby-2.0.0/bin/ruby /opt/apache2/ruby-2.0.0/bin/gem insta
----------------- lwp# 1 / thread# 1 --------------------
ffff80ffbf54aaaa lwp_kill () + a
ffff80ffbf4efeb9 raise () + 19
ffff80ffbf4c6632 abort () + ca
ffff80ffb5ed05c0 rb_bug_errno ()
ffff80ffb5f8cd0e sigsegv () + 4e
ffff80ffbf5418b6 _sighndlr () + 6
ffff80ffbf53503a call_user_handler () + 2ce
ffff80ffbf53525b sigacthandler (b, 5cfeb0, 5cfb50) + db
--- called from signal handler with signal 11 (SIGSEGV) ---
ffff80ffb5f6f6b4 onigenc_get_prev_char_head () + 24
ffff80ffb5f34255 ruby_yyparse () + 6f15
ffff80ffb5f36246 yycompile0 () + 156
ffff80ffb600791f rb_suppress_tracing () + df
ffff80ffb5f36345 yycompile () + 35
ffff80ffb5fe85ac parse_string () + 2c
ffff80ffb5fe86ff rb_iseq_compile_with_option () + 11f
ffff80ffb5ffdf44 eval_string_with_cref () + 234
ffff80ffb5ffe421 rb
f_eval () + 111
ffff80ffb5ff0c88 vm_call_cfunc_with_frame () + 348
ffff80ffb5ff5d6b vm_exec_core () + 2c7b
ffff80ffb60023bf vm_exec () + b0f
ffff80ffb6000a9a invoke_block_from_c () + 49a
ffff80ffb5ffcf93 rb_yield () + 73
ffff80ffb5e9d337 rb_ary_each () + 77
ffff80ffb5ff0c88 vm_call_cfunc_with_frame () + 348
ffff80ffb5ff5df9 vm_exec_core () + 2d09
ffff80ffb60023bf vm_exec () + b0f
ffff80ffb6000a9a invoke_block_from_c () + 49a
ffff80ffb5ffcf93 rb_yield () + 73
ffff80ffb5e9d337 rb_ary
each () + 77
ffff80ffb5ff0c88 vm_call_cfunc_with_frame () + 348
ffff80ffb5ff1f3b vm_call_method () + 39b
ffff80ffb5ff5df9 vm_exec_core () + 2d09
ffff80ffb60023bf vm_exec () + b0f
ffff80ffb5ffa736 vm_call0 () + 36
ffff80ffb5ffdb41 iterate_method () + a1
ffff80ffb5ffd797 rb_iterate () + 167
ffff80ffb5ffdbc0 rb_block_call () + 30
ffff80ffb5ec81a9 enum_collect () + 39
ffff80ffb5ff0c88 vm_call_cfunc_with_frame () + 348
ffff80ffb5ff1f3b vm_call_method () + 39b
ffff80ffb5ff5df9 vm_exec_core () + 2d09
ffff80ffb60023bf vm_exec () + b0f
ffff80ffb5ed93f3 rb_load_internal () + 173
ffff80ffb5ed9f95 rb_require_safe () + 1e5
ffff80ffb5ff0c88 vm_call_cfunc_with_frame () + 348
ffff80ffb5ff5d6b vm_exec_core () + 2c7b
ffff80ffb60023bf vm_exec () + b0f
ffff80ffb5ed52e5 ruby_exec_internal () + 95
ffff80ffb5ed53ee ruby_exec_node () + 1e
ffff80ffb5ed53b4 ruby_run_node () + 24
0000000000400f0c main () + 4c
0000000000400d5b ???????? ()
----------------- lwp# 2 / thread# 2 --------------------
ffff80ffbf54a66a _pollsys () + a
ffff80ffbf4f1995 pselect () + 181
ffff80ffbf4f1e14 select () + 68
ffff80ffb600a3ec thread
timer () + ac
ffff80ffbf541545 thrp_setup () + a5
ffff80ffbf5417f0 _lwp
start ()

History

#1 Updated by Yui NARUSE about 2 years ago

  • Assignee set to Naohisa Goto

#2 Updated by John Groenveld about 2 years ago

I'm not able to reproduce the core with the latest ruby on github
ruby 2.1.0dev (2013-03-08 trunk 39630) [x86_64-solaris2.11]

John
groenveld@acm.org

#3 Updated by Naohisa Goto about 2 years ago

  • Status changed from Open to Feedback

On sparc Solaris10, by using Oracle SolarisStudio 12.3, I cannot reproduce this issue with ruby 2.0.0p86 (svn ruby_2_0_0 r39852).

#4 Updated by Steve Klabnik over 1 year ago

John, can you get a small reproduction of some kind to help ngoto? It's been five months.

#5 Updated by Naohisa Goto over 1 year ago

  • Status changed from Feedback to Rejected

Closing because of lacking of reproduction.

Also available in: Atom PDF