Project

General

Profile

Bug #8045

Object#singleton_methods incompatible with prepend

Added by marcandre (Marc-Andre Lafortune) over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
r39608
[ruby-core:53209]

Description

Similar to #8044, although implementation is independent:

o=Object.new
def o.foo; end
o.singleton_methods(false) # => [:foo], ok
o.singleton_class.send :prepend, Enumerable
o.singleton_methods(false) # => [], should be [:foo]

Related issues

Is duplicate of Ruby trunk - Bug #8044: Object#methods incompatible with prependClosed2013-03-08

History

#1 [ruby-core:53363] Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF