Bug #8056

Random segmentation faults in Tempfile

Added by Wojciech Wnętrzak about 1 year ago. Updated 11 months ago.

[ruby-core:53262]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux] Backport:

Description

I'm getting random segmentation faults after switch to Ruby 2.0.0

I cannot reproduce it on my local machine, but it often happens when deploying to Heroku.
This is rails app with lot of other gem dependencies, so it might be hard to find responsible code for that.
Already submitted to rails bug tracker: https://github.com/rails/rails/issues/9608

Here is a stacktrace: https://gist.github.com/morgoth/a63eb1feebf5139e9537


Related issues

Duplicates ruby-trunk - Bug #8100: Segfault in trunk Closed 03/15/2013

History

#1 Updated by Magnus Holm 11 months ago

I'm guessing this is a duplicate of #8100.

#2 Updated by Yui NARUSE 11 months ago

  • Status changed from Open to Closed

Also available in: Atom PDF