Bug #8202

Turn off builded colorizing

Added by Denis Zinin about 1 year ago. Updated about 1 year ago.

[ruby-core:53882]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 1.9.3p385 (2013-02-06) [i386-mingw32] Backport:

Description

GD!

In Ruby 1.9.3 the output into console does not process escape secuences and it was good for me becouse i use ConEmu. ConEmu can process advanced escape secuences and some tools like pry theming worked perfectly. Now in ruby 2.0.0 the escape secuences are filtered and its bad for me. Pry theming not working. Background lighting (underline escape secuence) not working. Please say how to tirning off buildin in ruby 2.0 escape secuensec processing.

I think it will be better to introduce comand line key to disable builtin escape secuences processing (and it will be so better other way: special key to enable built-in escape processing). Anyway I think ruby never can give so wide support of escape secuences as it potentially can give external terminals. And so support is not ruby mission.

I think unacceptable that ruby forbid correct escape secuencecs output to external terminal. Standart windows console have winapi functions for very poor colorizing support. How do you want realize extended features of escape secuences by built-it in ruby? I want can define 256 palette with 24 bit colors. I want can use 24 bit pry-theme themes. I want can output any custom escape secuences into terminal. Winapi console function can't do that at all. Current approach with builtin escape processing make extended colorizing and others impossible. It seems very very strange that programming language make some output secuences impossible.

In conclusion. It will be better make spetial key or may be gem to enable or disable ruby escape processing for output.


Related issues

Related to ruby-trunk - Feature #8201: Turn off builded colorizing Closed 04/01/2013

History

#1 Updated by Luis Lavena about 1 year ago

  • Status changed from Open to Closed

Closed as duplicate of #8201 (which was moved to ruby-trunk)

Also available in: Atom PDF