Feature #8300

rails server request no working

Added by Aaron Devine 12 months ago. Updated 12 months ago.

[ruby-core:54476]
Status:Third Party's Issue
Priority:Low
Assignee:-
Category:-
Target version:-

Description

Can anyone help me figure out this error.

sk8devine$ rails server
/Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle: dlopen(/Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle, 9): Library not loaded: libmysqlclient.18.dylib (LoadError)
Referenced from: /Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle
Reason: image not found - /Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle
from /Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2.rb:9
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in require'
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in
require'
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in each'
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in
require'
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in each'
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in
require'
from /Library/Ruby/Gems/1.8/gems/bundler-1.3.5/lib/bundler.rb:132:in require'
from /Users/sk8devine/Sites/simple_cms/config/application.rb:7
from /Library/Ruby/Gems/1.8/gems/railties-3.2.13/lib/rails/commands.rb:53:in
require'
from /Library/Ruby/Gems/1.8/gems/railties-3.2.13/lib/rails/commands.rb:53
from /Library/Ruby/Gems/1.8/gems/railties-3.2.13/lib/rails/commands.rb:50:in tap'
from /Library/Ruby/Gems/1.8/gems/railties-3.2.13/lib/rails/commands.rb:50
from script/rails:6:in
require'
from script/rails:6

History

#1 Updated by Nobuyoshi Nakada 12 months ago

  • Status changed from Open to Third Party's Issue
  • Priority changed from Normal to Low

dlopen(/Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle, 9): Library not loaded: libmysqlclient.18.dylib (LoadError)
Referenced from: /Library/Ruby/Gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle
Reason: image not found

It's unacceptable to make libmysqlclient built-in as the language specification. ;-p

Also available in: Atom PDF