Project

General

Profile

Bug #8310

resque-web crashes with segfault on Ruby 2.0.0-p0 only, Resque 1.24.1, Redis 2.6.12

Added by Amit Aharoni about 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
ruby -v:
ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-darwin10.8.0]
[ruby-core:54509]

Description

To reproduce (assuming redis-server is running on your computer):
$ rvm use 2.0@clean
$ gem install resque
$ gem install redis
$ resque-web -F

This works on 1.9.3.

See crash reports and further details here:
https://github.com/vaharoni/resque_test

Issue also opened on Resque Github:
https://github.com/resque/resque/issues/966

History

#1 [ruby-core:54511] Updated by Amit Aharoni about 3 years ago

To clarify, after running resque-web, you have to wait 1-5 minutes for it to crash. Typically I click on "live-poll" at the bottom-left part of the webpage that opened, though that might be unnecessary.

#2 [ruby-core:54595] Updated by Zachary Scott about 3 years ago

Can you try this with trunk?
On Apr 22, 2013 5:38 PM, "vaharoni (Amit Aharoni)" amit.sites@gmail.com
wrote:

Issue #8310 has been updated by vaharoni (Amit Aharoni).

To clarify, after running resque-web, you have to wait 1-5 minutes for it
to crash. Typically I click on "live-poll" at the bottom-left part of the

webpage that opened, though that might be unnecessary.

Bug #8310: resque-web crashes with segfault on Ruby 2.0.0-p0 only, Resque
1.24.1, Redis 2.6.12
https://bugs.ruby-lang.org/issues/8310#change-38817

Author: vaharoni (Amit Aharoni)
Status: Open
Priority: Normal
Assignee:
Category:
Target version:
ruby -v: ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-darwin10.8.0]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN

To reproduce (assuming redis-server is running on your computer):
$ rvm use 2.0@clean
$ gem install resque
$ gem install redis
$ resque-web -F

This works on 1.9.3.

See crash reports and further details here:
https://github.com/vaharoni/resque_test

Issue also opened on Resque Github:
https://github.com/resque/resque/issues/966

--
http://bugs.ruby-lang.org/

#3 [ruby-core:54787] Updated by Timothy Raymond almost 3 years ago

@zzak Just tried it on trunk, seems fixed for me after ~15 minutes of running (v2.1.0dev with redis: 1.24.1, redis: 3.0.4) and I was able to reproduce this with v2.0.0p0 using the listed reproduction steps (seg fault in ~2 min) (same versions of redis and resque).

#4 [ruby-core:54807] Updated by Zachary Scott almost 3 years ago

  • Status changed from Open to Rejected

Duplicate of #8100

Also available in: Atom PDF