Bug #8347

Couldn't find file to include 'lib/rake/doc/README.rdoc' from ../lib/rake/version.rb

Added by Zachary Scott 12 months ago. Updated 11 months ago.

[ruby-core:54699]
Status:Closed
Priority:Normal
Assignee:Zachary Scott
Category:doc
Target version:2.1.0
ruby -v:ruby 2.1.0dev (2013-04-28 trunk 40515) [x86_64-darwin12.3.0] Backport:1.9.3: UNKNOWN, 2.0.0: UNKNOWN

Associated revisions

Revision 40535
Added by Zachary Scott 12 months ago

  • lib/rake/version.rb: Fix RDoc warning with :include: [Bug #8347]

History

#1 Updated by Zachary Scott 12 months ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r40535.
Zachary, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • lib/rake/version.rb: Fix RDoc warning with :include: [Bug #8347]

#2 Updated by Zachary Scott 12 months ago

  • Status changed from Closed to Assigned
  • % Done changed from 100 to 50

Fixed warning but ri does not work:

ri Rake does not show the README content, only "includes" and "extended by" for other classes

#3 Updated by Zachary Scott 11 months ago

  • Status changed from Assigned to Closed
  • % Done changed from 50 to 100

Fixed by r40535, looked like it wasn't working in ri because of excess whitespace before readme starts when using "ri Rake"

Also available in: Atom PDF