Project

General

Profile

Backport #8757

configure.in in 1.9.3. uses sed -E which does not work with gnu sed

Added by egh (Erik Hetzner) about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:<unknown>]

Description

This line in configure.in:

https://github.com/ruby/ruby/blob/ruby_1_9_3/configure.in#L2930

uses sed -E, which does not work with GNU sed. This is fixed in trunk with this patch:

https://github.com/ruby/ruby/commit/bb2e9e9e9871eab71aac3f316339c67e8bb4a1a5

Associated revisions

Revision b2a2fa42
Added by usa (Usaku NAKAMURA) over 5 years ago

merge revision(s) 37905: [Backport #8757]

    * configure.in (opt-dir): don't use non portable flag -E of sed.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@44820 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 44820
Added by usa (Usaku NAKAMURA) over 5 years ago

merge revision(s) 37905: [Backport #8757]

* configure.in (opt-dir): don't use non portable flag -E of sed.

History

Updated by hsbt (Hiroshi SHIBATA) over 5 years ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby master to Backport193
  • Assignee set to usa (Usaku NAKAMURA)

Updated by usa (Usaku NAKAMURA) over 5 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r44820.


merge revision(s) 37905: [Backport #8757]

* configure.in (opt-dir): don't use non portable flag -E of sed.

Also available in: Atom PDF