Bug #9034

Ruby

Added by Wang Michael 6 months ago. Updated 5 months ago.

[ruby-core:57926]
Status:Feedback
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-darwin12.2.0] Backport:1.9.3: UNKNOWN, 2.0.0: UNKNOWN

Description

when I run rspec in a rails application. I got

=> rspec
......

Finished in 14.88 seconds
6 examples, 0 failures

Randomized with seed 31062

/Users/gewang/.rvm/gems/ruby-2.0.0-p195/bin/rspec: [BUG] Segmentation fault
ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-darwin12.2.0]

-- Crash Report log information --------------------------------------------
See Crash Report log file under the one of following:
* ~/Library/Logs/CrashReporter
* /Library/Logs/CrashReporter
* ~/Library/Logs/DiagnosticReports
* /Library/Logs/DiagnosticReports
the more detail of.

-- Control frame information -----------------------------------------------
c:0001 p:0000 s:0002 E:000f48 TOP [FINISH]

-- C level backtrace information -------------------------------------------

-- Other runtime information -----------------------------------------------

  • Loaded script: /Users/gewang/.rvm/gems/ruby-2.0.0-p195/bin/rspec

  • Loaded features:

    0 enumerator.so
    1 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x8664-darwin12.2.0/enc/encdb.bundle
    2 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x86
    64-darwin12.2.0/enc/trans/transdb.bundle
    3 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x8664-darwin12.2.0/rbconfig.rb
    4 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/compatibility.rb
    5 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/siteruby/2.0.0/rubygems/defaults.rb
    6 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/deprecate.rb
    7 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/siteruby/2.0.0/rubygems/errors.rb
    8 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/version.rb
    9 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/siteruby/2.0.0/rubygems/requirement.rb
    10 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/platform.rb
    11 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/siteruby/2.0.0/rubygems/specification.rb
    12 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/exceptions.rb
    13 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/siteruby/2.0.0/rubygems/coreext/kernelgem.rb
    14 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/coreext/kernelrequire.rb
    15 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/siteruby/2.0.0/rubygems.rb
    16 /Users/gewang/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site
    ruby/2.0.0/rubygems/dependency.rb
    ......
    ......
    1250 /Users/gewang/.rvm/gems/ruby-2.0.0-p195/gems/actionpack-3.2.13/lib/actionview/flows.rb
    1251 /Users/gewang/.rvm/gems/ruby-2.0.0-p195/gems/actionpack-3.2.13/lib/action
    view/renderer/abstractrenderer.rb
    1252 /Users/gewang/.rvm/gems/ruby-2.0.0-p195/gems/actionpack-3.2.13/lib/action
    view/renderer/templaterenderer.rb
    1253 /Users/gewang/.rvm/gems/ruby-2.0.0-p195/gems/rspec-expectations-2.14.2/lib/rspec/matchers/built
    in/eq.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Abort trap: 6

The Gemfile I'm using

source 'https://rubygems.org'

gem 'rails', '3.2.13'
gem 'bootstrap-sass'
gem "font-awesome-rails"
gem 'jquery-datatables-rails', git: 'https://github.com/rweng/jquery-datatables-rails.git'
gem 'jquery-rails'

gem 'settingslogic'

gem 'rugged'
gem 'coderay'

gem 'capistrano'
gem 'capistrano-ext'
gem 'rvm-capistrano'

group :development, :test do
gem 'sqlite3'
gem "jasmine-headless-webkit", :require => false
end

group :development do
#gem 'pry'
end

group :test do
gem 'rspec-rails'
gem 'capybara'
#gem 'selenium-webdriver'
end

group :assets do
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
gem 'uglifier', '>= 1.0.3'
end

group :production do
gem 'mysql2'
gem 'unicorn'
end

Can anybody help to identify if this is a ruby bug or a gem bug?

ruby_2013-10-18-102857_LM-SHC-00355679.crash (12.8 KB) Wang Michael, 10/18/2013 11:48 AM

History

#1 Updated by Hiroshi SHIBATA 5 months ago

  • Status changed from Open to Feedback

Please try ruby-2.0.0p353 with your code.

Also available in: Atom PDF