Bug #9200

Segmentation Fault in jason 1.8.1 parser with Ruby 2.0.0 p353

Added by Jordan Stone over 1 year ago. Updated about 1 year ago.

[ruby-core:58803]
Status:Feedback
Priority:High
Assignee:-
ruby -v:2.0.0-p353 Backport:1.9.3: UNKNOWN, 2.0.0: UNKNOWN

Description

Trying to start the server for a brand new rails app using ruby 2.0.0 p353 results in a segmentation fault in the json parser gem.

ruby_2013-12-14-011123_Jerrys-MacBook-Pro.crash (19.8 KB) Jerry Keselman, 12/14/2013 03:33 PM

ruby_2014-01-18-220237_Amoss-MacBook-Pro.crash.gz - Crash report from "bundle exec rails s" (5.33 KB) Amos Shapira, 01/18/2014 11:11 AM

History

#1 Updated by Hiroshi SHIBATA over 1 year ago

  • Status changed from Open to Feedback

Can you attach crash log and add your development environment?

#2 Updated by Jerry Keselman over 1 year ago

I just had this similar crash. I'm a newbie, trying to go thru the Ruby on Rails Tutorial. I just ran rails generate scaffold User name:string email:string and got a segmentation fault. This is on OS/X, same ruby version, and same json parser.
jerrys-mbp:demo_app jerryk$ rails generate scaffold User name:string email:string
/Users/jerryk/.rvm/gems/ruby-2.0.0-p353/gems/json-1.8.1/lib/json/ext/parser.bundle: [BUG] Segmentation fault
ruby 2.0.0p247 (2013-06-27 revision 41674) [universal.x86_64-darwin13]

Adding the crash log.

#3 Updated by Amos Shapira about 1 year ago

Another occurance here. I'm trying to follow exercise 3 in section 3.5 of http://ruby.railstutorial.org/chapters/static-pages#sec-static_pages_exercises and get the same error on all commands after I tried to configure the Rails application with psql: "rake db:setup", "bundle exec rails s". Latest crash report, from "bundle exec rails s", is attached.
The database is up and "psql" manages to connect to it and execute commands on it.

Also available in: Atom PDF