Project

General

Profile

Feature #9209

Struct instances creatable with named args

Added by rits (First Last) over 3 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:58846]

Description

now that ruby supports named params it seems natural for Struct to make use of them.

Struct.new(:a).new(a: 1)


Related issues

Duplicates Ruby trunk - Feature #11925: Struct construction with kwargs Open

History

#1 [ruby-core:77758] Updated by herwinw (Herwin Quarantainenet) 5 months ago

This looks like a duplicate of #11925 (or maybe the other way around, but the other ticket includes more information)

#2 Updated by shyouhei (Shyouhei Urabe) 3 months ago

#3 [ruby-core:78762] Updated by shyouhei (Shyouhei Urabe) 3 months ago

  • Status changed from Open to Closed

please continue to issue #11925.

Also available in: Atom PDF