Project

General

Profile

Bug #9337

[BUG] Segmentation fault at 0x00000000000018 ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-linux]

Added by danielr (Daniel Ristic) about 6 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-linux]
Backport:
[ruby-core:59450]

Description

Tried to switch to ruby 2.1.0 on my rails app that runs on a linux server.

During deployment when executing rake assets:precompile I got a Segmentation fault error.

Tried to to the same thing locally (on a mac os system) and I got the same error.

Crash logs and diagnostic report attached.


Files

crash_report.txt (187 KB) crash_report.txt danielr (Daniel Ristic), 01/01/2014 08:49 PM
local_crash_report.txt (145 KB) local_crash_report.txt danielr (Daniel Ristic), 01/01/2014 08:49 PM
local_ruby_diagnostic_report.crash (19.6 KB) local_ruby_diagnostic_report.crash danielr (Daniel Ristic), 01/01/2014 08:49 PM

Updated by hsbt (Hiroshi SHIBATA) about 6 years ago

  • Status changed from Open to Feedback

Could you try to trunk version of Ruby? It seems to be fixed by r44458 probably.

Updated by summerspirit (Naomi Freeman) about 6 years ago

I also get this error, while running ruby 2.1.0 on my rails app, iMac, trying to run my first rspec test.

#3

Updated by jeremyevans0 (Jeremy Evans) 7 months ago

  • Backport deleted (1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN)
  • Status changed from Feedback to Closed

Also available in: Atom PDF