Bug #9497

segv with installing gems

Added by Aaron Patterson about 1 year ago. Updated about 1 year ago.

[ruby-core:60547]
Status:Rejected
Priority:Normal
Assignee:-
ruby -v:ruby 2.2.0dev (2014-01-29 trunk 44732) [x86_64-darwin13.0] Backport:1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN

Description

I'm getting a segv with trunk Ruby. To reproduce it do ruby -d -I lib -S gem install minitst -V. It seems to only happen when I give the -d flag.

I pasted the error I see here:

https://gist.github.com/tenderlove/8855116/raw/c7075108d583cd656d346f55a5e348aad9dd8aef/crash.txt

History

#1 Updated by Aaron Patterson about 1 year ago

I forgot to mention that this is in a checkout of the rubygems code. Here is the full reproduction steps:

$ git clone https://github.com/rubygems/rubygems.git
$ cd rubygems
$ ruby -d -I lib -S gem install minitst -V

I'm still trying to reduce the complexity of the example. :(

#2 Updated by Eric Wong about 1 year ago

I cannot reproduce the problem on r44870 (x86_64-linux)

It seems to only happen when I give the -d flag.

Can you reproduce the segv with GC disabled?

#3 Updated by Aaron Patterson about 1 year ago

Yes, it seems to still break with GC disabled. I'll rebuild with -g and see if I can get a backtrace.

#4 Updated by Aaron Patterson about 1 year ago

  • Status changed from Open to Rejected

I think this is my fault. Removing my installation and re-installing seemed to fix the problem.

Also available in: Atom PDF