Project

General

Profile

Bug #9561

Error downloading files from repository (.zip, .tar.gz, .tar.bz2, etc)

Added by Tilpa (fabio pasini) almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:61054]

Description

There are errors while downloading files from both "ftp" and "cache" repositories
(http://ftp.ruby-lang.org/pub/ruby/2.1/ and http://cache.ruby-lang.org/pub/ruby/2.1/),
the connection is closed from server side when there are few kB to complete download.

I got this error using different download tools (wget, curl, Firefox "Download" feature, and Firefox "DownThemAll" plugin).
That is happening for different files (.zip, .tar.gz, .tar.bz2, etc) from repositories above.

History

Updated by Tilpa (fabio pasini) almost 6 years ago

Some error logs

$ curl -O http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.1.zip
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
99 15.8M 99 15.7M 0 0 330k 0 0:00:49 0:00:48 0:00:01 0

curl: (56) Failure when receiving data from the peer

$ wget http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.1.zip
--2014-02-24 17:13:34-- http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.1.zip
Resolvendo cache.ruby-lang.org... 199.27.72.184, 199.27.76.184
Conectando-se a cache.ruby-lang.org|199.27.72.184|:80... conectado.
A requisição HTTP foi enviada, aguardando resposta... 200 OK
Tamanho: 16618363 (16M) [application/zip]
Salvando em: "ruby-2.1.1.zip.1"
99% [================================================> ] 16.487.269 --.-K/s em 46s

O cabeçalho Last-modified é inválido -- horário ignorado.
2014-02-24 17:14:22 (350 KB/s) - Erro de leitura no byte 16487269/16618363 (Conexão fechada pela outra ponta).

Updated by hsbt (Hiroshi SHIBATA) almost 6 years ago

  • Status changed from Open to Feedback
  • Assignee changed from nobu (Nobuyoshi Nakada) to hsbt (Hiroshi SHIBATA)

Do you still have this issue? I can't reproduce it in Japan.

We use CDN via fastly, probably this issue caused by our CDN.

Updated by normalperson (Eric Wong) almost 6 years ago

fabio (and anybody else for future reference):

Time and timezone of failed requests along with the requesting IP,
geographic location, user-agent would all be helpful for the CDN
provider to diagnose the problem.

Updated by Tilpa (fabio pasini) almost 6 years ago

Hi folks,

Do you still have this issue? I can't reproduce it in Japan.

Today, after trying again from the same machine/network, I've got the same errors (curl and wget failing as before).

We use CDN via fastly, probably this issue caused by our CDN.

I'll try again in a few hours from my home computer, which is in a different network, to see what happens there.

[]'s

Updated by Tilpa (fabio pasini) almost 6 years ago

I've tried again from home, and I was able to download successfully the file "ruby-2.1.1.zip" from both http://ftp.ruby-lang.org/pub/ruby/2.1/ and http://cache.ruby-lang.org/pub/ruby/2.1/
I also dowloaded ruby-2.0 without any problems, and all source files downloaded compiled ok here.

Please, feel free to set this issue as invalid.
Hiroshi, Eric, thanks a lot for checking this issue.

Updated by hsbt (Hiroshi SHIBATA) almost 6 years ago

  • Status changed from Feedback to Closed

Thank you for your feedback!

Also available in: Atom PDF