Project

General

Profile

Backport #9672

backport r45271

Added by zzak (Zachary Scott) about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:61665]

Description

cc #9592

Should we consider this for 1.9.3?


Related issues

Related to Ruby trunk - Bug #9592: Fix segfault with old OpenSSLClosed03/05/2014Actions

Associated revisions

Revision f150dbba
Added by usa (Usaku NAKAMURA) about 5 years ago

merge revision(s) 45271: [Backport #9672]

    * ext/openssl/ossl.c (ossl_make_error): check NULL for unknown
      error reasons with old OpenSSL, and insert a colon iff formatted
      message is not empty.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@45485 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 45485
Added by usa (Usaku NAKAMURA) about 5 years ago

merge revision(s) 45271: [Backport #9672]

* ext/openssl/ossl.c (ossl_make_error): check NULL for unknown
  error reasons with old OpenSSL, and insert a colon iff formatted
  message is not empty.

History

Updated by usa (Usaku NAKAMURA) about 5 years ago

I'll backport it because of it's a regression introduced at previous release,
But not to release for it.

Updated by usa (Usaku NAKAMURA) about 5 years ago

  • Related to Bug #9592: Fix segfault with old OpenSSL added

Updated by usa (Usaku NAKAMURA) about 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Applied in changeset r45485.


merge revision(s) 45271: [Backport #9672]

* ext/openssl/ossl.c (ossl_make_error): check NULL for unknown
  error reasons with old OpenSSL, and insert a colon iff formatted
  message is not empty.

Also available in: Atom PDF