Project

General

Profile

Bug #9900

Segmentation fault with recursive reference of a hash

Added by sawa (Tsuyoshi Sawada) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.2
[ruby-core:62931]

Description

The following code raises a segmentation fault.

Hash.new{|h,k| h[k]}[:foo]
# => [BUG] Segmentation fault at 0x007fff5f3fff80

This bug was found on stackoverflow http://stackoverflow.com/questions/24028557/irb-crash-segmentation-bug-and-ruby-syntax-clarification


Related issues

Is duplicate of Ruby trunk - Bug #9109: extend したモジュールメソッドと RSpec の let で 2 つ同名を使ったときに segmentation fault になるAssigned11/13/2013Actions

History

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Is duplicate of Bug #9109: extend したモジュールメソッドと RSpec の let で 2 つ同名を使ったときに segmentation fault になる added

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Status changed from Open to Closed

It may have been fixed already, but not sure because the link doesn't reveal the revision and the platform.

Also available in: Atom PDF