Project

General

Profile

Bug #10048

Time comparison broken on Windows, Ruby 1.9.3

Added by kmcd (k mcd) almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
1.9.3
[ruby-core:63778]

Description

Ruby 2.0 on OSX:

Time.parse("2014-07-15 14:25:04") <= Time.now
=> true

Ruby 1.9.3 on Windows 7 Embedded:

Time.parse("2014-07-15 14:25:04") <= Time.now
=> false

History

Updated by usa (Usaku NAKAMURA) almost 5 years ago

  • Priority changed from 5 to 3

Note that normal maintenance phase of 1.9.3 has already ended.

I can't reproduce it on my environment.

  • Windows 7 x64
  • ruby 1.9.3p545 (2014-02-24) [x64-mswin64_100]

Don't hide the result of ruby -v. We are not espers.

What is shown by the following code?

p Time.parse("2014-07-15 14:25:04")
p Time.now

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Description updated (diff)
  • Status changed from Open to Feedback

Updated by kmcd (k mcd) over 4 years ago

Not a bug - please close.

The embedded Windows system clock is incorrect.

(Not my choice to use embedded Windows).

Updated by zzak (Zachary Scott) over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF