Project

General

Profile

Bug #10272

miniruby hangs on Mac OS X 10.7

Added by jacknagel (Jack Nagel) about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
2.1.3
[ruby-core:65174]

Description

When compiling v2.1.3 with Apple's clang on Mac OS X 10.7, the build hangs while invoking the miniruby executable:

 $ make V=1 
    CC = clang
    LD = ld
    LDSHARED = clang -dynamic -bundle
    CFLAGS = --sysroot=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers -Wunused-variable -Wpointer-arith -Wwrite-strings -Wdeclaration-after-statement -Wshorten-64-to-32 -Wimplicit-function-declaration -Wdivision-by-zero -Wextra-tokens -pipe 
    XCFLAGS = -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -fvisibility=hidden -DRUBY_EXPORT -fPIE
    CPPFLAGS = -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT   -I. -I.ext/include/x86_64-darwin11.0 -I./include -I.
    DLDFLAGS = -Wl,-undefined,dynamic_lookup -Wl,-multiply_defined,suppress -fstack-protector -Wl,-u,_objc_msgSend -Wl,-pie -framework CoreFoundation  
    SOLIBS = 
Apple LLVM version 4.2 (clang-425.0.28) (based on LLVM 3.2svn)
Target: x86_64-apple-darwin11.4.2
Thread model: posix
./miniruby -I./lib -I. -I.ext/common  ./tool/mkconfig.rb -timestamp=.rbconfig.time \
        -install_name=ruby \
        -so_name=ruby rbconfig.rb

alternatively, it can be demonstrated by simply running make miniruby && ./miniruby -eexit.

The clang version in question is:

$ clang --version
Apple LLVM version 4.2 (clang-425.0.28) (based on LLVM 3.2svn)
Target: x86_64-apple-darwin11.4.2
Thread model: posix

I bisected it to r47276 on the v2_1_3 branch, but the issue is also present on trunk.


Related issues

Has duplicate Ruby master - Bug #10438: miniruby hangs on Mac 10.8.5 during build of ruby 2.1.4Closed10/28/2014Actions

Associated revisions

Revision 6c6d4da2
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48184 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 48184
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Revision 48184
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Revision 48184
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Revision 48184
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Revision 48184
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Revision 48184
Added by nobu (Nobuyoshi Nakada) almost 5 years ago

configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Revision fb3ed90d
Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago

merge revision(s) r48184: [Backport #10272] [Backport #10438]

    * configure.in (__builtin_setjmp): disable with gcc/clang earlier
      than 4.3 on Mac OS X.  [ruby-core:65174] [Bug #10272]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@48274 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 48274
Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago

merge revision(s) r48184: [Backport #10272] [Backport #10438]

* configure.in (__builtin_setjmp): disable with gcc/clang earlier
  than 4.3 on Mac OS X.  [ruby-core:65174] [Bug #10272]

History

Updated by nobu (Nobuyoshi Nakada) about 5 years ago

  • Category set to core
  • Status changed from Open to Feedback
  • Target version set to 2.2.0
  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN to 2.0.0: DONTNEED, 2.1: REQUIRED

Could you try configure --with-setjmp-type=setjmp?

Updated by jacknagel (Jack Nagel) about 5 years ago

Yes, that fixes it.

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Has duplicate Bug #10438: miniruby hangs on Mac 10.8.5 during build of ruby 2.1.4 added

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset r48184.


configure.in: fix for old Apple compilers

  • configure.in (__builtin_setjmp): disable with gcc/clang earlier than 4.3 on Mac OS X. [ruby-core:65174] [Bug #10272]

Updated by nagachika (Tomoyuki Chikanaga) almost 5 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: REQUIRED to 2.0.0: DONTNEED, 2.1: DONE

Backported into ruby_2_1 at r48274.

Also available in: Atom PDF